View Issue Details

IDProjectCategoryView StatusLast Update
0005884DarkRadiantGUIpublic13.02.2022 06:28
ReporterBikerdude Assigned Toorbweaver  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 (21H1)
Product Version2.14.0 
Fixed in Version3.0.0 
Summary0005884: Model chooser radio box selection issue:
DescriptionOpen up model chooser, then If you double click on any of textures that make up a model you will get taken back to the main DR window, this didnt happen in previous version of DR and can be a tad annoying.
TagsNo tags attached.

Activities

Bikerdude

Bikerdude

17.01.2022 10:12

reporter  

model_chooser_issue.jpg (264,848 bytes)
orbweaver

orbweaver

18.01.2022 20:11

developer   ~0014684

Reproduced. Must be some weird interaction with the default dialog close behaviour (e.g. when double-clicking on a file name in an Open dialog to immediately choose that file and close the dialog).
orbweaver

orbweaver

18.01.2022 21:18

developer   ~0014685

Fixed in 8ade7215cff22a47bc5bf3f673e5fbdae497967a
Bikerdude

Bikerdude

18.01.2022 22:34

reporter   ~0014686

Thanks Orbs.

Related Changesets

DarkRadiant: master 8ade7215

2022-01-18 21:10:42

orbweaver

Details Diff
0005884: double-clicking a model material no longer accepts dialog

Commit 9cfda496d31a0c5b40 introduced the ability to accept the ModelSelector
and create a model immediately on double-clicking in the model tree, however
the event handler was not bound to the _treeView but to the dialog itself. This
worked, because wxCommandEvents propagate upwards, however it also added the
unwanted behaviour of closing the dialog when double-clicking in the materials
list.

We now Bind() to the _treeView directly rather than to the dialog, ensuring
that only the main model tree can close the dialog with a double-click.
Affected Issues
0005884
mod - libs/wxutil/dialog/DialogBase.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File
mod - radiant/ui/modelselector/ModelSelector.cpp Diff File
mod - radiant/ui/modelselector/ModelSelector.h Diff File

Issue History

Date Modified Username Field Change
17.01.2022 10:12 Bikerdude New Issue
17.01.2022 10:12 Bikerdude File Added: model_chooser_issue.jpg
17.01.2022 10:12 Bikerdude Summary Model choose radio box selection issue => Model chooser radio box selection issue:
18.01.2022 20:11 orbweaver Assigned To => orbweaver
18.01.2022 20:11 orbweaver Status new => confirmed
18.01.2022 20:11 orbweaver Note Added: 0014684
18.01.2022 20:12 orbweaver Status confirmed => assigned
18.01.2022 21:18 orbweaver Status assigned => resolved
18.01.2022 21:18 orbweaver Resolution open => fixed
18.01.2022 21:18 orbweaver Fixed in Version => 3.0.0
18.01.2022 21:18 orbweaver Note Added: 0014685
18.01.2022 22:34 Bikerdude Note Added: 0014686
13.02.2022 06:28 orbweaver Changeset attached => DarkRadiant master 8ade7215