View Issue Details

IDProjectCategoryView StatusLast Update
0005918The Dark ModSaving/Loadingpublic15.12.2022 17:14
Reporterkingsal Assigned Tostgatilov  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformLinux 
Product VersionTDM 2.10 
Target VersionTDM 2.11Fixed in VersionTDM 2.11 
Summary0005918: Save game crash on Linux
DescriptionI've gotten a two reports of crashed from Linux users when using the new savegame function.

https://forums.thedarkmod.com/index.php?/topic/21264-fan-mission-hazard-pay-by-kingsal-tdm-beta-210-only/&do=findComment&comment=471463
Using the current function for example in Hazard pay:
$player1.saveGame("AUTO Desert");
Steps To ReproduceContact me and I can give a quick test map or point to the area in the mission.
TagsNo tags attached.

Activities

nbohr1more

nbohr1more

27.11.2022 18:25

developer   ~0015489

Might be related to 0005875

Crash was caused by quicksave screen-shot issues with SMP frames
stgatilov

stgatilov

27.11.2022 19:11

administrator   ~0015490

I don't think anything has changed here.
Daft Mugi

Daft Mugi

27.11.2022 20:23

reporter   ~0015492

This will probably be challenging to track down. I use Linux and have not had a crash on save, and "AUTO Desert" works.

I wonder what is different about their setup that causes the crash.
nbohr1more

nbohr1more

15.12.2022 04:44

developer   ~0015573

Marking as unable to reproduce until someone comes forward with a crash dump from 2.11 beta
stgatilov

stgatilov

15.12.2022 06:29

administrator   ~0015575

Hey, did you even try to reproduce it?
nbohr1more

nbohr1more

15.12.2022 17:14

developer   ~0015576

Yes, I attempted to replicate and did not encounter a crash. I will re-test tonight.

Issue History

Date Modified Username Field Change
09.03.2022 05:27 kingsal New Issue
15.11.2022 05:02 nbohr1more Severity normal => crash
27.11.2022 18:25 nbohr1more Note Added: 0015489
27.11.2022 18:25 nbohr1more Assigned To => stgatilov
27.11.2022 18:25 nbohr1more Status new => feedback
27.11.2022 19:11 stgatilov Note Added: 0015490
27.11.2022 20:23 Daft Mugi Note Added: 0015492
15.12.2022 04:44 nbohr1more Note Added: 0015573
15.12.2022 04:44 nbohr1more Status feedback => closed
15.12.2022 04:44 nbohr1more Resolution open => unable to reproduce
15.12.2022 04:44 nbohr1more Fixed in Version => TDM 2.11
15.12.2022 06:29 stgatilov Note Added: 0015575
15.12.2022 17:14 nbohr1more Note Added: 0015576