View Issue Details

IDProjectCategoryView StatusLast Update
0005973The Dark ModCodingpublic21.06.2022 19:24
Reporterstgatilov Assigned Tostgatilov  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.10 
Target VersionTDM 2.11Fixed in VersionTDM 2.11 
Summary0005973: Change crouch state on key down with crouch toggle
DescriptionSome players have requested that toggle crouch happen on key press rather than key release, which would make it behave like Thief and other games. When using toggle crouch on key release, a noticeable delay before crouching can be felt if the player does not quickly tap the crouch key. This has felt like a bug to some players who have not realized that crouching happens on key release.

https://forums.thedarkmod.com/index.php?/topic/21315-toggle-crouch-is-not-as-responsive/
https://forums.thedarkmod.com/index.php?/topic/21403-add-option-to-toggle-crouch-on-key-press/

(note: I cut this text from description of 0005962 by Daft Mugi)
Steps To ReproduceStart any mission with "toggle crouch" enabled.
Press the crouch key ('X' by default) with half-second duration.
The crouch state changes when you release the key up, while ideally it should change when you press the key down.
TagsNo tags attached.

Relationships

related to 0005962 new Add "new toggle crouch" 

Activities

stgatilov

stgatilov

12.06.2022 19:48

administrator   ~0014886

I looked through the patch provided by Daft Mugi at the linked thread.
I cut out a minimal change out of it and committed it in svn rev 9934.
stgatilov

stgatilov

21.06.2022 19:24

administrator   ~0014913

Committed almost the whole patch by Daft Mugi in svn rev 9945.

The reason is that sliding down was slightly broken: if you decide to slide from standing position, you end up crouched after slide is over.

The relevant discussion starts here:
  https://forums.thedarkmod.com/index.php?/topic/21403-add-option-to-toggle-crouch-on-key-press/&do=findComment&comment=475212

Issue History

Date Modified Username Field Change
12.06.2022 19:42 stgatilov New Issue
12.06.2022 19:42 stgatilov Status new => assigned
12.06.2022 19:42 stgatilov Assigned To => stgatilov
12.06.2022 19:42 stgatilov Relationship added related to 0005962
12.06.2022 19:48 stgatilov Note Added: 0014886
12.06.2022 19:48 stgatilov Status assigned => resolved
12.06.2022 19:48 stgatilov Resolution open => fixed
12.06.2022 19:48 stgatilov Fixed in Version => TDM 2.11
21.06.2022 19:24 stgatilov Note Added: 0014913