View Issue Details

IDProjectCategoryView StatusLast Update
0000102DarkRadiantMap Editingpublic27.02.2007 02:33
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.8.1 
Fixed in Version0.9.0 
Summary0000102: Able to create a brush of zero size
DescriptionDrag a brush, and then collapse one of the dimensions back on itself. At the origin, a brush of size x:-2, y:-2 will appear. Checking the entities list (L) will confirm that the brush is actually there.
TagsNo tags attached.

Activities

greebo

greebo

11.02.2007 20:12

administrator   ~0000092

Degenerate brushes are removed from the scene graph now and a warning is emitted to the console.
SneaksieDave

SneaksieDave

12.02.2007 22:41

developer   ~0000112

Hm, in the new version I got off the FTP, this seems to have some remnant of the issue left behind.

Create the brush and drag it back on itself as before; it disappears and the entity inspector is cleared. However, hit L to bring up the entity list, and note there is now a worldspawn entry. When it is selected, the brush of size (-2, -2) appears at the origin again. I don't know if this could eventually cause an error or not...
greebo

greebo

13.02.2007 07:14

administrator   ~0000116

Can't reproduce this, the brush is deleted and only worldspawn remains, with no children in the entity list. The worldspawn entry is ok, as there always has to be a worldspawn in the map.
SneaksieDave

SneaksieDave

13.02.2007 15:48

developer   ~0000125

To clarify a bit:
-On first starting a new map, there seems to be no worldspawn.
-Then, create a degenerate brush. It vanishes, all seems well.
-Now there IS a worldspawn, which is possibly not a problem in itself, but when I click the worldspawn entry in the list (L), the iso view jumps to the origin, with the same -2,-2 depiction as before.

If you can't repro that, then maybe it's fixed in recent versions and I'll wait for the next upload/drop/build to try again.
See image: http://img300.imageshack.us/my.php?image=badbrushcu5.jpg
greebo

greebo

13.02.2007 21:55

administrator   ~0000127

Sorry, I followed your steps and still, there appears to be no -2,-2 brush. Neither at the origin nor in the entity list as child of worldspawn.
SneaksieDave

SneaksieDave

25.02.2007 16:10

developer   ~0000209

I'm trying to add this feedback for the millionth time, let's hope it works :)
-------

Here are the exact steps in detail :)

-New map
-open entity list (L); it's completely blank. close the list
-drag a box
-grab one of the sides and collapse it to zero size. Don't let go!
-look at the origin; there will be negative coordinates showing on the origin
-now, let go; it vanishes
-open entity list again; there is a branch (+) entry. expand it. it has a worldspawn entry; click it. the negative coords are once again shown on the origin.

The image above (http://img300.imageshack.us/my.php?image=badbrushcu5.jpg) shows basically all I can show, and it happens every single time I do it.

As further documentation, here the contents (fully contained within the quotes) of,
1. A new, empty map:
"
Version 2
"

2. The map after creating this degenerate brush:
"
Version 2
// entity 0
{
"classname" "worldspawn"
"editor_drLastCameraPos" "0 0 0"
"editor_drLastCameraAngle" "0 0 0"
}
"

So something definitely changes. Perhaps it isn't a problem, but for some reason these negative coords are shown.
greebo

greebo

25.02.2007 16:48

administrator   ~0000210

Thanks, I had to turn on the "Show Size Info" option, now I can see the error. I suspect that this is a glitch in the sizeinfo code, not the brush drag code (which is probably fortunate, because easier to fix).
SneaksieDave

SneaksieDave

25.02.2007 16:56

developer   ~0000212

greebo

greebo

25.02.2007 17:20

administrator   ~0000215

SneaksieDave

SneaksieDave

26.02.2007 00:41

developer   ~0000234

It seems our last two comments have been erased. I was only saying 'sorry for not indicating to have size info turned on.'
greebo

greebo

26.02.2007 07:25

administrator   ~0000241

No problem, this is resolved now in SVN.

Issue History

Date Modified Username Field Change
11.02.2007 17:06 SneaksieDave New Issue
11.02.2007 18:00 greebo Assigned To => greebo
11.02.2007 18:00 greebo Status new => confirmed
11.02.2007 18:01 greebo Status confirmed => assigned
11.02.2007 20:12 greebo Status assigned => resolved
11.02.2007 20:12 greebo Fixed in Version => latest SVN
11.02.2007 20:12 greebo Resolution open => fixed
11.02.2007 20:12 greebo Note Added: 0000092
12.02.2007 22:41 SneaksieDave Status resolved => feedback
12.02.2007 22:41 SneaksieDave Resolution fixed => reopened
12.02.2007 22:41 SneaksieDave Note Added: 0000112
13.02.2007 07:14 greebo Note Added: 0000116
13.02.2007 15:48 SneaksieDave Note Added: 0000125
13.02.2007 21:55 greebo Note Added: 0000127
23.02.2007 22:25 greebo Status feedback => assigned
23.02.2007 22:25 greebo Assigned To greebo => SneaksieDave
23.02.2007 22:25 greebo Status assigned => feedback
25.02.2007 16:10 SneaksieDave Note Added: 0000209
25.02.2007 16:48 greebo Note Added: 0000210
25.02.2007 16:48 greebo Status feedback => assigned
25.02.2007 16:48 greebo Assigned To => greebo
25.02.2007 16:56 SneaksieDave Note Added: 0000212
25.02.2007 17:20 greebo Status assigned => resolved
25.02.2007 17:20 greebo Resolution reopened => fixed
25.02.2007 17:20 greebo Note Added: 0000215
26.02.2007 00:41 SneaksieDave Note Added: 0000234
26.02.2007 07:25 greebo Note Added: 0000241
27.02.2007 02:33 SneaksieDave Status resolved => closed