View Issue Details

IDProjectCategoryView StatusLast Update
0000108DarkRadiantRendererpublic29.03.2021 06:12
ReporterSneaksieDave Assigned Toorbweaver  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.8.1 
Target Version2.12.0Fixed in Version2.12.0 
Summary0000108: Ambients don't light sides facing away
DescriptionCreate a room with some pillars, and stick an ambient light right in the middle, covering the whole area. In render mode, the back faces of the pillars will not be lit. I tried both "Do not cast shadows" values on the light properties, and several different ambient light textures.
TagsNo tags attached.

Activities

orbweaver

orbweaver

12.02.2007 10:07

developer   ~0000100

Known issue -- ambient lights have been fixed for models, but they won't work properly for brushes.
orbweaver

orbweaver

23.02.2021 21:22

developer   ~0013726

I think this can be fixed since last year's lighting system refactoring, however I don't know if anybody is actually using traditional Doom 3 ambient lights now that the mod has the ambient_world system.
orbweaver

orbweaver

08.03.2021 21:06

developer   ~0013769

Fixed in 07a10bbff7569fcc1a95f385191a3b3501b0d724

Related Changesets

DarkRadiant: master 07a10bbf

2021-03-08 21:03:36

orbweaver

Details Diff
0000108: ambient lights now render correctly

Ambient lights had in fact never worked since the switch to GLSL, since the
ambient light code was only ever present in the old Cg shaders. The GLSL shader
is now updated to support ambient lights through a new bool uniform, which
works for both models and brushes.
Affected Issues
0000108
mod - include/iglprogram.h Diff File
mod - install/gl/interaction_fp.glsl Diff File
mod - radiantcore/rendersystem/backend/OpenGLShaderPass.cpp Diff File
mod - radiantcore/rendersystem/backend/glprogram/GLSLBumpProgram.cpp Diff File
mod - radiantcore/rendersystem/backend/glprogram/GLSLBumpProgram.h Diff File

Issue History

Date Modified Username Field Change
11.02.2007 22:27 SneaksieDave New Issue
12.02.2007 10:07 orbweaver Note Added: 0000100
12.02.2007 10:07 orbweaver Status new => confirmed
23.02.2021 21:20 orbweaver Assigned To => orbweaver
23.02.2021 21:20 orbweaver Status confirmed => assigned
23.02.2021 21:22 orbweaver Note Added: 0013726
08.03.2021 21:06 orbweaver Status assigned => resolved
08.03.2021 21:06 orbweaver Resolution open => fixed
08.03.2021 21:06 orbweaver Fixed in Version => 2.12.0
08.03.2021 21:06 orbweaver Note Added: 0013769
08.03.2021 21:06 orbweaver Target Version => 2.12.0
29.03.2021 06:12 orbweaver Changeset attached => DarkRadiant master 07a10bbf