View Issue Details

IDProjectCategoryView StatusLast Update
0001104The Dark ModAIpublic03.01.2020 06:19
ReporterHappyCheeze Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0001104: Gas arrows leak through glass and doors
DescriptionI have knocked out guards that are next to glass or a door, by shooting the gas arrow at the door or glass at head level.

Additional InformationThe glass in question has the same thickness as the door, about 4 units thick.

The said door was the atdm:door_96x48_3hinge.
TagsNo tags attached.

Relationships

related to 0000048 new Stim Response through walls 
related to 0005017 resolvedstgatilov Mine explosions have a light, fire arrow explosions don't 

Activities

grayman

grayman

09.04.2013 19:53

administrator   ~0005287

Don’t allow gas arrows to leak through barriers. If the stim can find a path through a barrier, however, and the opening is close enough to the target, the target will react.

Don’t allow gas stims to be processed on KO’ed or dead AI, or doused lights.

Don’t allow gas stims to be processed on AI bodies that have heads. The heads will deal with the response.

Fix bug introduced with delayed visual stim work (0002924). Fire arrows give off visual stims in flight, but the arrow is removed upon impact. Needed to account for a null stim source when the visual stim delay expired.

Gas and fire arrows now impact at the water’s surface. Gas arrows will give off the gas cloud, and fire arrows will create a puff of smoke.

Adjusted where the mouth is on AIs.

rev. 5734:

AI_events.cpp
Physics_Liquid.cpp
Physics_RigidBody.cpp
Actor.cpp
Actor.h
Game_local.cpp
Game_local.h
Projectile.cpp
Projectile.h
AI.cpp
AI.h

rev 13406:

Tdm_weapon_firearrow.def
Tdm_weapon_gasarrow.def
grayman

grayman

09.04.2013 19:55

administrator   ~0005288

There are probably instances where the architecture looks like it will allow the stim to work, and it doesn't.

And vice versa.

Finding openings through barriers is a tradeoff between complete coverage and not performing too many traces.

For the cases where a wall stands between the stim and the entity, however, the entity should never react.
grayman

grayman

17.05.2013 14:15

administrator   ~0005477

A further fix is necessary to handle the case of separate flames and holders.

Rev. 5796:

Game_local.cpp
Game_local.h

Issue History

Date Modified Username Field Change
12.09.2008 05:15 HappyCheeze New Issue
12.09.2008 11:57 greebo Status new => confirmed
06.04.2013 14:11 grayman Relationship added related to 0000048
06.04.2013 14:11 grayman Assigned To => grayman
06.04.2013 14:11 grayman Status confirmed => assigned
09.04.2013 19:53 grayman Note Added: 0005287
09.04.2013 19:53 grayman Status assigned => resolved
09.04.2013 19:53 grayman Resolution open => fixed
09.04.2013 19:53 grayman Fixed in Version => TDM 2.00
09.04.2013 19:53 grayman Target Version => TDM 2.00
09.04.2013 19:55 grayman Note Added: 0005288
17.05.2013 14:15 grayman Note Added: 0005477
03.01.2020 06:19 stgatilov Relationship added related to 0005017