View Issue Details

IDProjectCategoryView StatusLast Update
0000119DarkRadiantGUIpublic16.03.2007 04:33
ReporterSneaksieDave Assigned Toorbweaver  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.0 
Summary0000119: Entity descriptions missing
DescriptionSource: http://modetwo.net/darkmod/index.php?s=&showtopic=5384&view=findpost&p=100374

The blue group in the Add Property dialog doesn't contain property descriptions. This is in the build up on FTP as of 2/12/07. An image demonstrating the issue exists in the above link.

Edit: The hope would of course be that these would include _all_ available properties, like DoomEd. I'm not sure where they're defined (they don't seem to be in the DEF files), but if only custom ones showed up, it wouldn't be terribly helpful. The AI for instance have more than 50 properties in all.
TagsNo tags attached.

Activities

orbweaver

orbweaver

13.02.2007 16:06

developer   ~0000126

Currently it only looks for the properties defined in the entityDef itself, using "editor_var blah" and "editor_bool blah". It does not currently process properties inherited from parent entityDefs, which may be the issue here.
orbweaver

orbweaver

19.02.2007 10:57

developer   ~0000161

The inheritance does seem to be the issue -- the example entityDef's given do not define their own custom variables, but they may inherit from a superclass which does. Ideally these inherited custom variables should be listed too.
orbweaver

orbweaver

21.02.2007 11:12

developer   ~0000179

Fixed in SVN.
SneaksieDave

SneaksieDave

23.02.2007 02:17

developer   ~0000185

Last edited: 23.02.2007 02:19

Is there a possibility I don't have this code from greebo's new texturetool build? I still get nothing:

http://img91.imageshack.us/my.php?image=nopropslf2.jpg

Edit: make that for *some* things, I get nothing. atdm:mover_door does show me extended properties...

orbweaver

orbweaver

25.02.2007 20:12

developer   ~0000229

There are two bugs here:

1. Problem with DefTokeniser not terminating comments that end in "**/" resulting in certain parent classes not being loaded -- RESOLVED.
2. The inheritance resolution is a single pass and non-recursive, so not all properties are propagated -- OUTSTANDING
orbweaver

orbweaver

04.03.2007 12:07

developer   ~0000316

Entity class inheritance should now be fixed in SVN. I checked a number of classes and they all display with custom properties (including AI).
SneaksieDave

SneaksieDave

04.03.2007 17:14

developer   ~0000329

I saw differences on checking out the builder guard, so I dug a bit deeper. Let's use the builder forger instead, for example. Some differences noted:

1.
In DR, the following three fields are default:
classname, name, origin
In DoomEd, we are shown:
classname, name, origin, anim

Why the anim field isn't shown, I don't know. Importance in terms of general editing, unknown.

2.
In DoomEd, some selected items that show up in the properties list for the forger (I really wish I could just dump the list from the editors):

eye_turn_min, eye_turn_max, eye_vertical_offset
def_attach
head
FOV
no_idle_chatter
alert_threshN

This is just a brief sampling, I definitely did not go through the hundred or so in the list. None of these show up for the forger in DR as either inherited properties, nor in the Add Property dialog. The blue atdm:ai_builder_forger folder is also empty for this character, but that is almost certainly not where the missing props would show up; they don't exist there for a builder guard either (aside from alert_threshN - why that is there and the others aren't, I do not know). Bits and pieces here and there seem to be getting picked up, but I guess until it hits all the sources DoomEd hits (and the question arises, does DoomEd even cover them all?) the lists will never agree.
greebo

greebo

04.03.2007 17:33

administrator   ~0000332

The issue has been fixed after I uploaded a new build, so you're probably working with the unfixed version. Uploading now...
SneaksieDave

SneaksieDave

04.03.2007 18:42

developer   ~0000334

With newest SVN downloaded about 10 mins ago (1:30 EST) I still get the same fields not showing, empty "blue" folder, etc... :(
orbweaver

orbweaver

04.03.2007 21:03

developer   ~0000340

Confirmed that ai_builder_forger does not display the inherited properties, even though it supposedly inherits from ai_humanoid which IS populated with custom properties.
orbweaver

orbweaver

08.03.2007 13:55

developer   ~0000362

Whoops, boolean flag was not initialised to false in constructor resulting in inheritance failure for some entities.
SneaksieDave

SneaksieDave

16.03.2007 04:33

developer   ~0000418

Definitely looks much more populated.
Will track individual problems as/if found.

Issue History

Date Modified Username Field Change
13.02.2007 15:10 SneaksieDave New Issue
13.02.2007 15:18 SneaksieDave Description Updated
13.02.2007 16:06 orbweaver Note Added: 0000126
13.02.2007 16:06 orbweaver Status new => acknowledged
19.02.2007 10:56 orbweaver Status acknowledged => assigned
19.02.2007 10:56 orbweaver Assigned To => orbweaver
19.02.2007 10:57 orbweaver Note Added: 0000161
21.02.2007 11:12 orbweaver Status assigned => resolved
21.02.2007 11:12 orbweaver Fixed in Version => latest SVN
21.02.2007 11:12 orbweaver Resolution open => fixed
21.02.2007 11:12 orbweaver Note Added: 0000179
23.02.2007 02:17 SneaksieDave Status resolved => feedback
23.02.2007 02:17 SneaksieDave Resolution fixed => reopened
23.02.2007 02:17 SneaksieDave Note Added: 0000185
23.02.2007 02:19 SneaksieDave Note Edited: 0000185
25.02.2007 20:11 orbweaver Status feedback => assigned
25.02.2007 20:12 orbweaver Note Added: 0000229
04.03.2007 12:07 orbweaver Status assigned => resolved
04.03.2007 12:07 orbweaver Resolution reopened => fixed
04.03.2007 12:07 orbweaver Note Added: 0000316
04.03.2007 17:14 SneaksieDave Status resolved => feedback
04.03.2007 17:14 SneaksieDave Resolution fixed => reopened
04.03.2007 17:14 SneaksieDave Note Added: 0000329
04.03.2007 17:33 greebo Note Added: 0000332
04.03.2007 18:42 SneaksieDave Note Added: 0000334
04.03.2007 21:03 orbweaver Note Added: 0000340
04.03.2007 21:03 orbweaver Status feedback => assigned
08.03.2007 13:55 orbweaver Status assigned => resolved
08.03.2007 13:55 orbweaver Resolution reopened => fixed
08.03.2007 13:55 orbweaver Note Added: 0000362
16.03.2007 04:33 SneaksieDave Status resolved => closed
16.03.2007 04:33 SneaksieDave Note Added: 0000418