View Issue Details

IDProjectCategoryView StatusLast Update
0000124DarkRadiantRendererpublic21.02.2007 04:42
ReporterSneaksieDave Assigned Toorbweaver  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.8.1 
Fixed in Version0.9.0 
Summary0000124: Many light textures cast no light in render mode
DescriptionNot sure why exactly, but it seems a great many (most) light textures cast no light in render mode. At first I assumed it was about animated textures not being rendered at all (which does seem to be the case) but there are also static lights showing up as black.

Examples:
biground_candleflicker (animated): no light
biground1 (static): no light
brightround (static): does cast light

Perhaps not 'major', but it does cripple render mode pretty badly. For instance, if you have an area lit with flickering torches, it'll be fully dark in render mode.
TagsNo tags attached.

Activities

greebo

greebo

15.02.2007 08:28

administrator   ~0000133

Last edited: 15.02.2007 08:29

Have you tested this with the 0.8.1 release or my snapshot (have to make sure, because there were some changes in the snapshot that altered the lightfalloff image texture creation)?

orbweaver

orbweaver

15.02.2007 10:48

developer   ~0000140

Last edited: 15.02.2007 10:49

Confirmed with lights/biground1 (latest SVN)

SneaksieDave

SneaksieDave

15.02.2007 17:23

developer   ~0000147

Also confirmed for 0.8.1.
greebo

greebo

15.02.2007 18:47

administrator   ~0000150

phew, I thought it could have been introduced by me when refactoring the ShaderSystem texture handling.
orbweaver

orbweaver

15.02.2007 19:43

developer   ~0000151

I thought I fixed this before 0.8.x, I'll have to take another look.
orbweaver

orbweaver

17.02.2007 10:21

developer   ~0000157

Seems to be caused by the GLTextureManager defaulting to _black.bmp for undefined Z falloff textures. Shaders plugin to be modified to use the falloff from the defualt point light shader instead.
orbweaver

orbweaver

18.02.2007 12:36

developer   ~0000158

Resolved in SVN.
SneaksieDave

SneaksieDave

20.02.2007 04:07

developer   ~0000166

Last edited: 20.02.2007 04:08

I'm getting really weird behavior here. It's like it's trying to work; I can see traces of the true light texture in each choice I make, but they're all trashed by striped bands and blue blotches:

http://img294.imageshack.us/my.php?image=bluext0.jpg

Brightround (and doubleround) still look right, but just about everything else looks like some variation of the above. That's just a square room with a single light in it.

greebo

greebo

20.02.2007 07:21

administrator   ~0000168

Maybe this is the "Shader Not Found" texture used as lightfalloff?
orbweaver

orbweaver

20.02.2007 11:32

developer   ~0000171

Last edited: 20.02.2007 12:02

I can't replicate this, all of the textures work fine for me. Do you have the correct default light shader listed in doom3.game? It should be lights/defaultpointlight.

SneaksieDave

SneaksieDave

20.02.2007 16:13

developer   ~0000174

Seems so. From doom3.game:
...
    <defaults>
        <lightShader>lights/defaultpointlight</lightShader>
...
orbweaver

orbweaver

20.02.2007 16:51

developer   ~0000176

It should be formatted like this:

<defaults>
    <lightShader value="lights/defaultpointlight" />

I gather greebo has produced another build, so the latest version should be in that (or you can change it manually).
SneaksieDave

SneaksieDave

21.02.2007 04:42

developer   ~0000178

That seems to have fixed it.

Issue History

Date Modified Username Field Change
15.02.2007 03:12 SneaksieDave New Issue
15.02.2007 03:39 SneaksieDave Description Updated
15.02.2007 08:28 greebo Note Added: 0000133
15.02.2007 08:29 greebo Note Edited: 0000133
15.02.2007 10:39 greebo Assigned To => SneaksieDave
15.02.2007 10:39 greebo Status new => feedback
15.02.2007 10:48 orbweaver Note Added: 0000140
15.02.2007 10:48 orbweaver Status feedback => confirmed
15.02.2007 10:49 orbweaver Note Edited: 0000140
15.02.2007 17:23 SneaksieDave Note Added: 0000147
15.02.2007 18:47 greebo Note Added: 0000150
15.02.2007 19:42 orbweaver Status confirmed => assigned
15.02.2007 19:42 orbweaver Assigned To SneaksieDave => orbweaver
15.02.2007 19:43 orbweaver Note Added: 0000151
17.02.2007 10:21 orbweaver Note Added: 0000157
18.02.2007 12:36 orbweaver Status assigned => resolved
18.02.2007 12:36 orbweaver Fixed in Version => latest SVN
18.02.2007 12:36 orbweaver Resolution open => fixed
18.02.2007 12:36 orbweaver Note Added: 0000158
20.02.2007 04:07 SneaksieDave Status resolved => feedback
20.02.2007 04:07 SneaksieDave Resolution fixed => reopened
20.02.2007 04:07 SneaksieDave Note Added: 0000166
20.02.2007 04:08 SneaksieDave Note Edited: 0000166
20.02.2007 07:21 greebo Note Added: 0000168
20.02.2007 11:32 orbweaver Note Added: 0000171
20.02.2007 12:02 orbweaver Note Edited: 0000171
20.02.2007 16:13 SneaksieDave Note Added: 0000174
20.02.2007 16:51 orbweaver Note Added: 0000176
21.02.2007 04:42 SneaksieDave Status feedback => closed
21.02.2007 04:42 SneaksieDave Note Added: 0000178
21.02.2007 04:42 SneaksieDave Resolution reopened => fixed