View Issue Details

IDProjectCategoryView StatusLast Update
0000141DarkRadiantGUIpublic20.03.2021 09:21
ReporterSneaksieDave Assigned Toorbweaver  
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.0 
Fixed in Version2.0.0 
Summary0000141: File dialog Name sorting is case sensitive
DescriptionAny way I could convince to make it not case sensitive? I've been nothing but struggling with these dialogs since they were first added (admittedly from a windows user perspective, but they are just alien and unfriendly as hell to me, and it's not improving despite a week or so of use - I swear every time I'm in the wrong folder, it takes me at least 20 seconds to get where I want to be), and I finally figured out at least one reason why they're so clunky for me - the Name column sorting is case sensitive, with caps coming before lowercase. So, /TDM and /DarkRadiant and /WinCVS, etc., sort before /darkmod and /base, etc. It's driving me insane to be completely honest. :)

Failing that, I don't suppose there's a way to have the win32 build use windows dialogs?
TagsNo tags attached.

Activities

orbweaver

orbweaver

23.02.2007 09:48

developer   ~0000191

I just opened the GIMP in Windows (which also uses GTK) and the open dialog uses case-insensitive sorting, so this is definitely possible. It may be a simple option or perhaps we need to upgrade the version of GTK used.
greebo

greebo

30.12.2008 15:25

administrator   ~0002277

Last edited: 30.12.2008 15:25

I suppose the GIMP in windows compiles GTK directly from source. I had a look at the GTK 2.14.5 sources, and this is how the sort function looks like:

/* Sort callback for the filename column */
static gint
name_sort_func (GtkTreeModel *model,
        GtkTreeIter *a,
        GtkTreeIter *b,
        gpointer user_data)
{
  COMPARE_DIRECTORIES;
  else
    {
      gchar *key_a, *key_b;
      gint result;

      key_a = g_utf8_collate_key_for_filename (g_file_info_get_display_name (info_a), -1);
      key_b = g_utf8_collate_key_for_filename (g_file_info_get_display_name (info_b), -1);
      result = strcmp (key_a, key_b);

      g_free (key_a);
      g_free (key_b);

      return result;
    }
}

Note the use of strcmp. There is also no method exposed to change the sort function or get hold of the treemodel behind the GtkFileChooserDialog.

Either we compile GTK+ from source or we suspend this issue...

orbweaver

orbweaver

25.05.2009 11:33

developer   ~0002487

Cannot be fixed without recompiling GTK, maybe a future release of GTK will expose the required functionality.
SneaksieDave

SneaksieDave

16.10.2009 01:10

reporter   ~0002685

Suspended then, yes?
SneaksieDave

SneaksieDave

31.12.2009 19:37

reporter   ~0002807

Suspended or closed? Sounded like it could be done in the future, but it was marked closed (causing it to fall of the radar), not suspended.
orbweaver

orbweaver

20.03.2021 09:21

developer   ~0013798

This was effectively resolved by the migration to wxWidgets, which no longer uses GTK dialogs on Windows.

Issue History

Date Modified Username Field Change
23.02.2007 02:41 SneaksieDave New Issue
23.02.2007 09:48 orbweaver Note Added: 0000191
23.02.2007 09:48 orbweaver Status new => assigned
23.02.2007 09:48 orbweaver Assigned To => orbweaver
30.12.2008 15:25 greebo Note Added: 0002277
30.12.2008 15:25 greebo Note Edited: 0002277
25.05.2009 11:33 orbweaver Note Added: 0002487
25.05.2009 11:33 orbweaver Status assigned => resolved
25.05.2009 11:33 orbweaver Resolution open => not fixable
16.10.2009 01:10 SneaksieDave Note Added: 0002685
16.10.2009 01:10 SneaksieDave Status resolved => suspended
18.12.2009 07:43 greebo Status suspended => closed
31.12.2009 19:37 SneaksieDave Note Added: 0002807
31.12.2009 19:37 SneaksieDave Assigned To orbweaver =>
31.12.2009 19:37 SneaksieDave Status closed => suspended
20.03.2021 09:21 orbweaver Assigned To => orbweaver
20.03.2021 09:21 orbweaver Status suspended => resolved
20.03.2021 09:21 orbweaver Resolution not fixable => fixed
20.03.2021 09:21 orbweaver Fixed in Version => 2.0.0
20.03.2021 09:21 orbweaver Note Added: 0013798