View Issue Details

IDProjectCategoryView StatusLast Update
0000142DarkRadiantMap Editingpublic22.03.2007 17:16
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.0 
Summary0000142: No single click to deselect control points?
DescriptionA suggestion. When using both DoomEd and DR,

1. clicking control points on a patch selects them, one at a time
2. shift-clicking adds to the selection
3. rubber banding is possible with shift-drag
4. ctrl-click does nothing (apparently)
5. a single click of an unselected point will select it, and deselect all others.

What I find issue with is 4. and 5. together. Ctrl-click should be individual select toggle (this is standard selection behavior), and only ESC should clear all (also, pretty standard behavior). 5. is a major crippling annoyance since the first time I ever tried to work with patches. If you are selecting in top down view, for instance, just a few random points among a web of many, because you wish to make them all into bumps or valleys, you do so by clicking and rubber banding. Fine. Then, you rotate your view to a side view, and click to drag the control points up or down to make your valleys or bumps, right? Wrong. Your single click has now DESELECTED everything you picked to adjust. Because of a poor, nonstandard selection method. If only ESC cleared all, and ctrl-click was to selectively toggle, this would finally no longer be an issue.

If what I'm describing here isn't clear, just let me know and I'll throw something together (map or images or whatever).
TagsNo tags attached.

Activities

greebo

greebo

08.03.2007 22:30

administrator   ~0000366

Should be fixed.

Patch vertices can be toggled by Shift-LMB (as standard in DarkRadiant) and the current vertex selection does not get reset by left-clicking on a non-selected vertex (it's added to the selection instead).
SneaksieDave

SneaksieDave

22.03.2007 17:16

developer   ~0000440

thanks! big improvement over DoomEd.

Issue History

Date Modified Username Field Change
23.02.2007 03:06 SneaksieDave New Issue
23.02.2007 08:28 greebo Description Updated
23.02.2007 08:29 greebo Status new => acknowledged
08.03.2007 22:30 greebo Status acknowledged => resolved
08.03.2007 22:30 greebo Fixed in Version => latest SVN
08.03.2007 22:30 greebo Resolution open => fixed
08.03.2007 22:30 greebo Assigned To => greebo
08.03.2007 22:30 greebo Note Added: 0000366
22.03.2007 17:16 SneaksieDave Status resolved => closed
22.03.2007 17:16 SneaksieDave Note Added: 0000440