View Issue Details

IDProjectCategoryView StatusLast Update
0000177DarkRadiantGUIpublic25.03.2007 15:19
ReporterSneaksieDave Assigned Toorbweaver  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.0 
Summary0000177: Use proper skin in lit or even textured mode
DescriptionI know this has been mentioned on the boards casually, but I don't think it's been reported. It'd be desirable to have entities display the actual skin they use in lit mode, if not in textured mode as well.
TagsNo tags attached.

Activities

orbweaver

orbweaver

04.03.2007 20:55

developer   ~0000338

This has already been fixed for static meshes, but I think it is still outstanding for AI.
SneaksieDave

SneaksieDave

05.03.2007 14:49

developer   ~0000341

Fixed as in 'in the past' or 'as of now'? The thing that prompted me to enter this was that I don't see the proper skin on wall paintings in rain.map with as recently as yesterday's SVN. I didn't try all other types; when I came across the painting, I'd just assumed that meant it wasn't implemented at all yet.
orbweaver

orbweaver

05.03.2007 17:03

developer   ~0000344

It should work now for static meshes. Is there an example model/skin I can test with?
SneaksieDave

SneaksieDave

05.03.2007 19:18

developer   ~0000345

Open rain.map (on SVN) and note the paintings on the wall. They should all be different.
orbweaver

orbweaver

06.03.2007 21:26

developer   ~0000355

Confirmed. This is because all of the pictures use the same model, so they are all instances of the same model object (which is where the skin processing is done). If you change the skin on one of them, they ALL change.

Nice to know the model instancing is working though.
orbweaver

orbweaver

13.03.2007 10:55

developer   ~0000408

Per-instance skinning is now implemented, so instances of the same model can have a different skin. Loading rain.map now shows each picture with its own skin.
SneaksieDave

SneaksieDave

25.03.2007 15:19

developer   ~0000495

sweet!

Issue History

Date Modified Username Field Change
04.03.2007 19:11 SneaksieDave New Issue
04.03.2007 20:55 orbweaver Note Added: 0000338
04.03.2007 20:55 orbweaver Status new => confirmed
05.03.2007 14:49 SneaksieDave Note Added: 0000341
05.03.2007 17:03 orbweaver Note Added: 0000344
05.03.2007 19:18 SneaksieDave Note Added: 0000345
06.03.2007 16:52 orbweaver Status confirmed => assigned
06.03.2007 16:52 orbweaver Assigned To => orbweaver
06.03.2007 21:26 orbweaver Note Added: 0000355
13.03.2007 10:55 orbweaver Status assigned => resolved
13.03.2007 10:55 orbweaver Fixed in Version => latest SVN
13.03.2007 10:55 orbweaver Resolution open => fixed
13.03.2007 10:55 orbweaver Note Added: 0000408
25.03.2007 15:19 SneaksieDave Status resolved => closed
25.03.2007 15:19 SneaksieDave Note Added: 0000495