View Issue Details

IDProjectCategoryView StatusLast Update
0001874The Dark ModAIpublic28.03.2013 20:08
Reporterangua Assigned To 
PrioritynormalSeveritynormalReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionSVN 
Summary0001874: Sleeping AI - clipping and gravity issues
DescriptionSleeping AI clipping into the bed
AI falling through the ground when getting up
AI hovering above the ground while laying down or getting up
AI not obeying to gravity after getting up
TagsNo tags attached.

Relationships

has duplicate 0002416 resolvedgrayman Sleeping AI can fall through the ground when they wake up 

Activities

grayman

grayman

28.03.2013 20:08

administrator   ~0005255

I'm going to mark this resolved.

AI hover above a bed or clip into it because the sleeping animation is independent of where the bed is. Mappers typically adjust the bed height to accommodate this. I don't think it's worth the coding time to make it perfect.

AI are usually placed a few units above the floor by the mapper, so that they can settle onto the floor properly during the first dozen frames. AI that start out sleeping don't lower to the floor first, and when they return to standing, they return to where they started, a few units above the floor. Once the stand up anim is done, the AI drops to the floor. While this is problematic, the solution is to delay the start of the lying down animation until after the AI has dropped to the floor. Since a workaround of placing an AI only 1 unit above the floor is a much simpler solution than reworking the timing of events during the first couple dozen frames, I don't think we should bother changing the code.

I fixed the problem of AI falling through the floor when standing up. See 0002416.

Issue History

Date Modified Username Field Change
30.07.2009 10:31 angua New Issue
19.11.2010 11:19 tels Relationship added has duplicate 0002416
28.03.2013 20:08 grayman Note Added: 0005255
28.03.2013 20:08 grayman Status new => resolved
28.03.2013 20:08 grayman Resolution open => fixed