View Issue Details

IDProjectCategoryView StatusLast Update
0000192DarkRadiantGUIpublic03.05.2007 23:26
ReporterSneaksieDave Assigned ToSneaksieDave  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.0 
Summary0000192: Crash on opening surf inspector after choose shader
Description-open surface inspector
-hit shader button, select a shader, hit OK
-click the ortho view to set focus
-toggle the surface inspector on and off and back on again

I get a reproducable crash at this point.
TagsNo tags attached.

Activities

greebo

greebo

10.03.2007 18:38

administrator   ~0000378

Can't reproduce that. Is this happening with a specific map?
SneaksieDave

SneaksieDave

11.03.2007 15:45

developer   ~0000384

Discussion ongoing in thread.
http://modetwo.net/darkmod/index.php?showtopic=5547&st=0&#entry104166
greebo

greebo

11.03.2007 17:55

administrator   ~0000389

Last edited: 11.03.2007 17:55

I've uploaded a new build to FTP, please test it again with this one. It's in the /TheDarkmod/DarkRadiant folder, as usual. (3 min. from now)

SneaksieDave

SneaksieDave

13.03.2007 00:24

developer   ~0000401

It took a bunch of tries, but I did get the crash. The difference seemed to be changing focus to the ortho view [i]before[/i] toggling the surface inspector off. When I toggled it off, and then gave the ortho focus, it didn't happen. But if I:

-opened it, picked a shader
-clicked ortho
-hit S (to toggle off surf inspector) and again to toggle back on,

I got the crash. I wonder if there's something about my frankenstein install. Are these SVN drops full zips, or just changes? If they are full, I could give a whole new install a try...
greebo

greebo

24.03.2007 20:23

administrator   ~0000471

SneaksieDave, do you still get the crash with the new build? I'm uploading one right now (21:00 CET)
SneaksieDave

SneaksieDave

25.03.2007 14:23

developer   ~0000484

Last edited: 25.03.2007 14:23

Yep, I got the crash same as before. :(

That's with all new xmls.

greebo

greebo

25.03.2007 14:33

administrator   ~0000486

By the life of me, I tried it yet again, I get no crash. We have to find a way to investigate this.
SneaksieDave

SneaksieDave

25.03.2007 14:35

developer   ~0000489

This may not fix it, but... do we need that Choose Shader button? The functionality is redundant, since the user could just as well go to the media and textures tabs.

Kind've a brute force method to fix the crash, but if it works, it works. :)
greebo

greebo

25.03.2007 14:38

administrator   ~0000490

I'd rather not cut features out of the code instead of finding the cause of this. We will find another way, but it may involve some DarkRadiant reinstallations, to be absolutely sure that no old stuff is causing this.
greebo

greebo

02.05.2007 09:56

administrator   ~0000612

SneaksieDave, is this still reproducible?
SneaksieDave

SneaksieDave

03.05.2007 23:26

developer   ~0000614

So far I am not getting it. I tried a bunch of restarts and a bunch of toggling it on and off, on and off, no crash. I think maybe we can close this. I'll keep an eye out for it and reopen with info if I come across it again.

Issue History

Date Modified Username Field Change
10.03.2007 16:46 SneaksieDave New Issue
10.03.2007 18:38 greebo Note Added: 0000378
10.03.2007 18:38 greebo Assigned To => SneaksieDave
10.03.2007 18:38 greebo Status new => feedback
11.03.2007 15:45 SneaksieDave Note Added: 0000384
11.03.2007 17:55 greebo Note Added: 0000389
11.03.2007 17:55 greebo Note Edited: 0000389
13.03.2007 00:24 SneaksieDave Note Added: 0000401
24.03.2007 20:23 greebo Note Added: 0000471
25.03.2007 14:23 SneaksieDave Note Added: 0000484
25.03.2007 14:23 SneaksieDave Note Edited: 0000484
25.03.2007 14:33 greebo Note Added: 0000486
25.03.2007 14:35 SneaksieDave Note Added: 0000489
25.03.2007 14:38 greebo Note Added: 0000490
02.05.2007 09:56 greebo Note Added: 0000612
03.05.2007 23:26 SneaksieDave Status feedback => closed
03.05.2007 23:26 SneaksieDave Note Added: 0000614
03.05.2007 23:26 SneaksieDave Resolution open => fixed
03.05.2007 23:26 SneaksieDave Fixed in Version => 0.9.0