View Issue Details

IDProjectCategoryView StatusLast Update
0000193DarkRadiantGUIpublic07.05.2007 16:37
ReporterSneaksieDave Assigned Toorbweaver  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.0 
Summary0000193: Some new player equipment models show collision mesh even with filter on
DescriptionI'm not sure if this is a problem with the models or some aspect of the DR filter which is missing.

All of Pinkdot's most recent player equipment models (gasmine, flashbomb, spyglass) show the collision model even with the filter turned on.
TagsNo tags attached.

Activities

orbweaver

orbweaver

10.03.2007 21:53

developer   ~0000381

Are these static meshes selected with the model browser or entity classes with models associated?
SneaksieDave

SneaksieDave

11.03.2007 15:43

developer   ~0000383

I'm not sure if I understood the question, but this is just from RMB->create model. In that view, these few items show a collision model even with the filter on.

In all likelihood, something is strange about the models, but I thought maybe DR's filter was missing something.
angua

angua

11.03.2007 19:34

manager   ~0000391

Maybe they have the new collision textures? I think Pinkdot mentioned something about a collection of new collision textures for different materials.
orbweaver

orbweaver

11.03.2007 20:36

developer   ~0000392

Added tdm_collision_* to the Collision Surface filter in the .game file.
SneaksieDave

SneaksieDave

20.03.2007 16:23

developer   ~0000433

Last edited: 20.03.2007 16:26

I think something's still up, or maybe it shifted from one place to another:
Whereas now I can filter collision surfaces so that I don't see them in the model chooser dialog, I now can't seem to shut them off in the map views (both ortho and cam). Place a diamond, or gold plate loot, for example. They have pentagonal collision(?) meshes showing with the filter on either mode.

http://img119.imageshack.us/my.php?image=collmeshhh9.jpg

orbweaver

orbweaver

24.03.2007 14:08

developer   ~0000459

The per-instance skinning required to allow different skins on the same model had broken the filter check, fixed now in SVN.

Issue History

Date Modified Username Field Change
10.03.2007 16:46 SneaksieDave New Issue
10.03.2007 21:53 orbweaver Note Added: 0000381
10.03.2007 21:53 orbweaver Status new => feedback
11.03.2007 15:43 SneaksieDave Note Added: 0000383
11.03.2007 19:34 angua Note Added: 0000391
11.03.2007 20:33 orbweaver Status feedback => assigned
11.03.2007 20:33 orbweaver Assigned To => orbweaver
11.03.2007 20:36 orbweaver Status assigned => resolved
11.03.2007 20:36 orbweaver Fixed in Version => latest SVN
11.03.2007 20:36 orbweaver Resolution open => fixed
11.03.2007 20:36 orbweaver Note Added: 0000392
20.03.2007 16:23 SneaksieDave Status resolved => feedback
20.03.2007 16:23 SneaksieDave Resolution fixed => reopened
20.03.2007 16:23 SneaksieDave Note Added: 0000433
20.03.2007 16:26 SneaksieDave Note Edited: 0000433
24.03.2007 14:03 orbweaver Status feedback => assigned
24.03.2007 14:08 orbweaver Status assigned => resolved
24.03.2007 14:08 orbweaver Resolution reopened => fixed
24.03.2007 14:08 orbweaver Note Added: 0000459
07.05.2007 16:37 orbweaver Status resolved => closed