View Issue Details

IDProjectCategoryView StatusLast Update
0002011DarkRadiantGUIpublic28.03.2018 15:32
ReporterSneaksieDave Assigned Touser81 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version1.0.2 
Fixed in Version2.5.0 
Summary0002011: Launch associated editor for definitions from context menu
DescriptionI don't *think* this has been officially reported, though it has been mentioned on the forums in the past.

The request for a custom material editor comes up often, or one for XDs, or sound shaders, defs, etc... This is reported to be a very big and complex task, and is probably not a great use of developer time.

As a quick and dirty alternative:
* The user opens a context menu (right click) on the desired texture or sound or book or whatever,
* DR issues a run command to the OS, which launches the user's operating system's current file association (e.g. notepad) for the relevant file containing their desired definition (the proper .mtr, .sndshd, .xd, .def, whatever)
* If the user has no current association (e.g., .xd is associated with nothing) then too bad for them, DR issues the command and the OS ignores it

I've written an application in Qt which does this, and it's a one line statement, so this should be very easy and get the masses to stop requesting this feature. ;)
TagsNo tags attached.

Activities

greebo

greebo

02.11.2009 20:42

administrator   ~0002729

What should happen if the file in question is contained in a PK4?
SneaksieDave

SneaksieDave

02.11.2009 22:31

developer   ~0002730

Last edited: 02.11.2009 22:32

Does DR have unzip libraries built in? Since it does/will have PK4 support, I would guess it must. Would that allow you to browse the PK4 and get access to the file in question?

After it's launched in the editor, it's up to the user to save it properly or not. IMO, the DR part of it should just be getting them easy access to the data they want to see, after which, they're on their own.

In fact, if it is packed in PK4, and we don't worry about the saving process, then the zip library could definitely browse and extract the data, and dump it to the associated editor, then dust its hands free of the task. What I was picturing (as the "easy" method... maybe not so much) was just a DR supported file association, and literally *nothing* more.

greebo

greebo

03.11.2009 05:48

administrator   ~0002731

Hm. So let's say the editor can be used to launch the editor for the d3_hell_base.mtr file. The user now has the editor open and can see the material file (DR cannot make it scroll to the selected material, remember). Then the user starts editing the file and -- now what? Hitting "Save file" will save the temporary file. How is the user supposed know which PK4 he should save the changed file back to? Isn't this a half-assed solution?
SneaksieDave

SneaksieDave

03.11.2009 14:28

developer   ~0002732

Last edited: 03.11.2009 14:29

IMO, and considering the alternatives (1. no help from DR at all, or 2. building a full fledged text editor in DR with PK4 extraction and injection support anyway, which may never happen or will take a long time), it's quite good enough. If they are using this feature they hopefully know enough which file it came from (DR tells them) and that they will be saving a new version of it. Usually it will probably be their own files they just want quick access to. Instead of, "which file is it? okay... open explorer... browse through multiple folders to file... scroll down to it... open it manually...", it would just be a context menu click in DR, and done!

I think the benefit is worthy, despite the limitations:
-sometimes they'll just be wanting to inspect the file,
-sometimes they'll want to create a new file from another,
-sometimes they'll need a file in a pk4 and when saving time comes, they'll need to know what to do (oh well)
-mainly though, I'd think they'll be using it to edit their *own* local materials and shaders and definitions and especially books; those will already be unpacked.

Let's discuss on forum yes? http://modetwo.net/darkmod/index.php?/topic/10152-launch-associated-editor-functionality-in-darkradiant/

user81

28.03.2018 15:32

  ~0010288

A bunch of the requested functionality is now present in DR.

Issue History

Date Modified Username Field Change
02.11.2009 20:16 SneaksieDave New Issue
02.11.2009 20:42 greebo Note Added: 0002729
02.11.2009 22:31 SneaksieDave Note Added: 0002730
02.11.2009 22:32 SneaksieDave Note Edited: 0002730
03.11.2009 05:48 greebo Note Added: 0002731
03.11.2009 14:28 SneaksieDave Note Added: 0002732
03.11.2009 14:29 SneaksieDave Note Edited: 0002732
28.03.2018 15:32 user81 Note Added: 0010288
28.03.2018 15:32 user81 Status new => closed
28.03.2018 15:32 user81 Assigned To => user81
28.03.2018 15:32 user81 Resolution open => fixed
28.03.2018 15:32 user81 Fixed in Version => 2.5.0