View Issue Details

IDProjectCategoryView StatusLast Update
0002103DarkRadiantGUIpublic21.12.2010 12:18
ReporterSneaksieDave Assigned Togreebo  
PrioritylowSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.1 
Target Version1.2.2Fixed in Version1.2.2 
Summary0002103: Switch to/from render mode requires explicit mouselook click to display
DescriptionVery minor issue, and in fact, if it's the result of a performance optimization, I'll withdraw this issue completely; the single click is worth it if it's making other things faster. Just reporting in case it indicates something broken.

While not in mouselook mode, toggle render mode on or off. Note that no change is shown until you explicitly click to edit something or enter mouselook mode. I'm assuming this is just a missing refresh call or something.

Update: something weird going on. If I right click to open context menu, then right click again, I _can_ toggle render mode on/off. So it's like it's stuck in some kind of mode or focus. For the issue above, use RMB to drag the ortho view around, release, then try to toggle render mode -- requires another RMB click.
TagsNo tags attached.

Activities

greebo

greebo

14.01.2010 07:04

administrator   ~0002883

Hm, cannot see this issue here. I'm using Embedded layout.

- Open Radiant, draw a few brushes and lights
- Switch to lighting mode back and fort, works
- Drag-Right-Click the Orthoview, releaes mouse button
- Hit F3 to switch modes, works
SneaksieDave

SneaksieDave

16.01.2010 15:07

developer   ~0002886

I take back my assertion that this is very minor. I just tried tweaking my clip distance for 5 mins before I realized why it wasn't working -- I had to issue explicit actions to get the cam view to redraw.

I get it with embedded too, though I usually use splitpane.
- launch, build stuff or open a map
- RMB ortho
- hit F3 -- no change in cam view
- RMB cam -- render mode shows
- RMB cam again (disabling mouselook)
- Hit F3 -- cursor disappears from cam window, but render mode still shows
- EITHER tab away to a different application and back, or RMB ortho -- cam window updates and shows non-render mode

Another:
- set up hotkeys to draw the clipping plane in or out
- watching the cam, draw the plane in a few clicks, then stop
- RMB the cam -- it hops one more click forward (it happened when you pressed it, but didn't draw, so it's one hop behind)
- can do the same moving the plane outward, always its one click behind

I see this type of stuff with our draw issues on our software at work all the time, and it always comes down to issuing an explicit redraw after change (apparently there's an implicit redraw on focus shift).
SneaksieDave

SneaksieDave

16.01.2010 15:26

developer   ~0002887

See here: http://modetwo.net/darkmod/index.php?/topic/10554-cam-refresh-issue/page__view__findpost__p__207377

Problem might be resolved.
SneaksieDave

SneaksieDave

23.03.2010 02:35

developer   ~0002946

New info here:
http://modetwo.net/darkmod/index.php?/topic/10554-cam-refresh-issue/page__view__findpost__p__212818
SneaksieDave

SneaksieDave

06.05.2010 22:52

developer   ~0003010

Note to self: Keep an eye out for this with 1.3+. I was getting it with 1.02, then changed nvidia display mode (dual -> horiz stretch) and it was fixed. Tried it in 1.3 beta and all seemed okay, but that could be because of the switch.

Issue History

Date Modified Username Field Change
13.01.2010 15:15 SneaksieDave New Issue
13.01.2010 15:17 SneaksieDave Description Updated
14.01.2010 07:04 greebo Note Added: 0002883
14.01.2010 07:04 greebo Status new => feedback
16.01.2010 15:07 SneaksieDave Note Added: 0002886
16.01.2010 15:26 SneaksieDave Note Added: 0002887
23.03.2010 02:35 SneaksieDave Note Added: 0002946
23.03.2010 02:35 SneaksieDave Status feedback => new
24.03.2010 17:05 greebo Status new => acknowledged
06.04.2010 16:34 greebo Status acknowledged => assigned
06.04.2010 16:34 greebo Assigned To => greebo
06.04.2010 16:34 greebo Status assigned => resolved
06.04.2010 16:34 greebo Fixed in Version => 1.2.2
06.04.2010 16:34 greebo Resolution open => fixed
06.04.2010 16:34 greebo Target Version => 1.2.2
06.05.2010 22:52 SneaksieDave Note Added: 0003010
21.12.2010 12:18 greebo Status resolved => closed