View Issue Details

IDProjectCategoryView StatusLast Update
0000211DarkRadiantGUIpublic01.05.2007 15:18
ReporterSneaksieDave Assigned Toorbweaver  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.0 
Summary0000211: Strange behavior from undefined fields in entity inspector?
DescriptionNot sure what's going on here, but I guess it could be a side-effect from the recent issue with properties not showing for some objects.

Add a map object, "target_tdm_addobjectives" (I'd never heard of this till I saw it in bonehoard). I assume this object is not finished, as indicated by the descriptions. Open the 'blue folder' in Add Props, and start clicking down the duplicated entries, noting the result. It's unclear where the descriptions are coming from, and which property they belong to. At the bottom of the list, mouseover the folders below and then back up the list. Very bizarre - the entries become renamed as the folders below, or whatever you previously moused over.
TagsNo tags attached.

Activities

orbweaver

orbweaver

16.03.2007 09:42

developer   ~0000421

The custom properties in question contained markup symbols ("" and "<j>") which were confusing GTK. These are now properly escaped.
SneaksieDave

SneaksieDave

07.04.2007 01:22

developer   ~0000532

Rather than enter a new one, I'll ask in this entry -

1. Should the properties appear as, e.g.:
obj_<j>_args_int
obj_<j>_args_str
...

in the blue folder, or is that a problem?

2. The resulting added property seems to be problematic. When for instance I add the first item in the list, the entity winds up with a key named:

obj_<j>_args_int
orbweaver

orbweaver

07.04.2007 17:03

developer   ~0000540

Last edited: 07.04.2007 17:04

The angle bracket stuff is what is written in the DEF file, it stands for the number you insert (e.g. obj1_2_blah). Previously this was being interpreted as HTML which is used to contrl the text formatting, but because it was not well-formed an error was caused. I have added an extra step to escape the control characters which results in the > stuff.

Not sure how best to deal with this, unless I just say that non-alphanumeric characters are not supported and ignored the property altogether, or strip out the characters rather than escaping them.

greebo

greebo

08.04.2007 07:54

administrator   ~0000541

Why not change the "editor_bla" strings to something less problematic?
orbweaver

orbweaver

08.04.2007 11:09

developer   ~0000542

I have fixed this by escaping only the display name text, not the property name text (which is used when you click OK in the AddPropertyDialog). It doesn't make much sense to add these properties manually (and you still have to edit in the correct values), but at least it behaves correctly if you do.
SneaksieDave

SneaksieDave

01.05.2007 15:18

developer   ~0000603

Okay, I believe I understand the explanations.
These values will be ultimately added by the Objectives Editor (WIP) and although it doesn't really make much sense for a user to add them by hand, and they'd have to change "i" and "j" values to the proper number values, they still could do so if they wished, using these (now properly escaped) keys as a template.

Issue History

Date Modified Username Field Change
16.03.2007 05:09 SneaksieDave New Issue
16.03.2007 09:23 orbweaver Status new => assigned
16.03.2007 09:23 orbweaver Assigned To => orbweaver
16.03.2007 09:42 orbweaver Status assigned => resolved
16.03.2007 09:42 orbweaver Fixed in Version => latest SVN
16.03.2007 09:42 orbweaver Resolution open => fixed
16.03.2007 09:42 orbweaver Note Added: 0000421
07.04.2007 01:22 SneaksieDave Status resolved => feedback
07.04.2007 01:22 SneaksieDave Resolution fixed => reopened
07.04.2007 01:22 SneaksieDave Note Added: 0000532
07.04.2007 17:03 orbweaver Note Added: 0000540
07.04.2007 17:03 orbweaver Note Edited: 0000540
07.04.2007 17:04 orbweaver Note Edited: 0000540
08.04.2007 07:54 greebo Note Added: 0000541
08.04.2007 11:09 orbweaver Status feedback => resolved
08.04.2007 11:09 orbweaver Resolution reopened => fixed
08.04.2007 11:09 orbweaver Note Added: 0000542
01.05.2007 15:18 SneaksieDave Status resolved => closed
01.05.2007 15:18 SneaksieDave Note Added: 0000603