View Issue Details

IDProjectCategoryView StatusLast Update
0002228The Dark ModCodingpublic07.07.2013 22:31
ReporterSneaksieDave Assigned Tograyman  
PriorityurgentSeveritycrashReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
Product VersionTDM 1.02 
Summary0002228: Water arrow + lantern bot = crash
DescriptionI've confirmed reports "from the field" that sending a water arrow into the face of a lanter bot will crash out TDM.
TagsNo tags attached.

Activities

grayman

grayman

23.09.2010 03:52

administrator   ~0003192

I'm trying to reproduce this with 1.02 and can't.

I've fired dozens of water arrows into a lanternbot's face and can't crash TDM. The bot stops moving and sounds his alarm. I've tried him on team 0 and team 16 with the same results. I've hit him with water arrows and other arrows from all sides, with no crashes.

The test map I'm using is a lanternbot patrolling 4 path_corners in a single room, me, weapons, and a light.

Is this still happening out in the field?
grayman

grayman

23.09.2010 03:53

administrator   ~0003193

I'm testing on Win32.

Are the crashes occurring on Win64 or Linux, perhaps?
nbohr1more

nbohr1more

23.09.2010 15:32

developer   ~0003195

Last edited: 23.09.2010 15:39

View 2 revisions

I have been searching but cannot find it... There was some reference to problems that affect only Core2Duo and newer CPU architectures... (I hope that the reporting was erroneous or someone will need to buy you a new PC).

Fidcal

Fidcal

05.03.2011 22:26

updater   ~0003702

Don't know if it's related but I'm getting random crashes when a lanternbot is alerted. No arrow - just heard me. It may be that the water arrow caused an alert so it might be the same problem. As I recall, water arrows cause an alert on AI not from sound but if they are within the splash area. I'll see if I can reproduce it in a test map over the next few days.
Fidcal

Fidcal

08.03.2011 15:17

updater   ~0003737

I now have a test map where just firing a noisemaker arrow at a wall to cause an alert always immediately crashes to desktop. Both SVN & 1.04. PM me for map if anyone working on this.
grayman

grayman

08.03.2011 19:04

administrator   ~0003739

The crash comes from the bot having no AAS areas to move around in.

The bot in your test map sits outside of the calculated AAS96 areas. Dmap then says since there are no AI inside the AAS96 areas that need AAS96, it doesn't write the *.aas96 file.

When the mission starts, you get a warning message saying "AAS96 is out of date".

When I move the bot into the center of the room, *.aas96 gets written, the map comes up okay, and he's alerted by a noisemaker and there's no crash.

So ...

1 - If all lanternbots in a mission are too close to a wall or monster_clip, dmap doesn't create the *.aas96 file and you get a warning at mission start.

2 - If all lanternbots are in "okay" places, dmap creates the *.aas96 file and all is well.

3 - If all lanternbots are then moved close to a wall, dmap won't create a new *.aas96 file, and won't delete the old one. The map comes up okay, there's no error message, and all is well.

As with any architectural changes, it's best to delete any *.aasN files before dmapping. That guarantees that they match the architecture. Any start-time warnings are then due to a particular AAS file not being created, so the AI need to be adjusted.
grayman

grayman

07.07.2013 22:31

administrator   ~0005660

It's been almost three years since the last report of this, so I'm closing it as not reproducible.

Issue History

Date Modified Username Field Change
26.05.2010 18:51 SneaksieDave New Issue
26.05.2010 18:53 SneaksieDave Reproducibility always => sometimes
05.06.2010 07:29 greebo Target Version TDM 1.03 =>
23.09.2010 03:52 grayman Note Added: 0003192
23.09.2010 03:53 grayman Note Added: 0003193
23.09.2010 15:32 nbohr1more Note Added: 0003195
23.09.2010 15:39 nbohr1more Note Edited: 0003195 View Revisions
05.03.2011 22:26 Fidcal Note Added: 0003702
08.03.2011 15:17 Fidcal Note Added: 0003737
08.03.2011 18:03 grayman Assigned To => grayman
08.03.2011 18:03 grayman Status new => assigned
08.03.2011 19:04 grayman Note Added: 0003739
07.07.2013 22:31 grayman Note Added: 0005660
07.07.2013 22:31 grayman Status assigned => resolved
07.07.2013 22:31 grayman Resolution open => unable to reproduce