View Issue Details

IDProjectCategoryView StatusLast Update
0000223DarkRadiantMap Editingpublic15.06.2007 20:50
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.1 
Summary0000223: Problems with selecting multi-part func_* with cam view
DescriptionIt seems that depending on how/where you select, e.g., a func_static, you may or may not select all parts with a single click.

-Create a func_static, or func_door, or whatever, out of three cubes.
-Select one of the cubes in the cam view.

I noticed recently that selecting them in the cam view gets one at a time, while selecting them in an ortho view gets the whole object at once. I thought this might be by design, and might be helpful, but through usage I realized it has drawbacks and some bugs. (I'm breaking a cardinal QA rule here not to stack defects, but this apparently depends on the main subject, so I'll include these in one entry)

1. it makes it very hard to work with such func_* sometimes, because selecting things in the ortho views is not always the easiest task
2. selecting such entities in the cam view doesn't allow you to revert to worldspawn (selecting in ortho view does)
3. since selecting in the cam view is seen as an 'individual selection' process, as soon as you select more than one part of the func_*, the entity inspector goes blank, so you can't edit the properties.
4. probably more undiscovered effects similar to 2 and 3.
TagsNo tags attached.

Activities

greebo

greebo

24.03.2007 18:44

administrator   ~0000464

Fixed (phew, this was tough!)
SneaksieDave

SneaksieDave

15.06.2007 20:50

developer   ~0000678

Looks like it worked :)

Issue History

Date Modified Username Field Change
23.03.2007 02:13 SneaksieDave New Issue
23.03.2007 05:51 greebo Status new => assigned
23.03.2007 05:51 greebo Assigned To => greebo
24.03.2007 18:44 greebo Status assigned => resolved
24.03.2007 18:44 greebo Fixed in Version => latest SVN
24.03.2007 18:44 greebo Resolution open => fixed
24.03.2007 18:44 greebo Note Added: 0000464
15.06.2007 20:50 SneaksieDave Status resolved => closed
15.06.2007 20:50 SneaksieDave Note Added: 0000678
15.06.2007 20:50 SneaksieDave Fixed in Version 0.9.0 => 0.9.1