View Issue Details

IDProjectCategoryView StatusLast Update
0002251DarkRadiantDesign/Codingpublic07.07.2015 09:26
Reporteruser81Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
PlatformCorei5/GTX970OSWindows x64OS Version8
Product Version2.0.1 
Target Version2.0.2Fixed in Version2.0.2 
Summary0002251: DR 1.3.1: Any items dragged snap back to original location
DescriptionWhen I drag any object/brush/patch etc, if I don't click off said item after moving it sometimes reverts back to its old location, highly annoying.
TagsNo tags attached.

Activities

greebo

greebo

10.06.2010 16:09

administrator   ~0003053

I'm not really sure what you mean - are you saying you need to left-click to finish the drag operation?

user81

11.06.2010 12:16

  ~0003061

Grrrr, now when I try and repro it, it isnt doing it - I`ll be back here with the exact steps when it does it again.
grayman

grayman

26.06.2010 13:19

administrator   ~0003097

1. Select an item.
2. Left-click it and drag it. While dragging, click the right mouse button.
3. Release the item.
4. Left-click it again and it will jump back to where it was.

It's as if the accidental right-click while dragging queues up an undo which occurs the next time you left-click.

This also happens if you're dragging a brush face to resize it.
greebo

greebo

27.06.2010 03:54

administrator   ~0003098

Ok, I can see it now, when right-clicking you're basically interrupting the operation and the object data is not "frozen" in that position.

user81

27.06.2010 08:43

  ~0003099

Last edited: 11.01.2013 09:36

View 2 revisions

ah, so I wasnt going mad then...

user81

18.07.2010 17:35

  ~0003131

I confirm for me at least, that this is fixed in 1.4.0pre.
grayman

grayman

19.07.2010 14:10

administrator   ~0003137

When I right-click during dragging (brush or item), the object goes back to its start position immediately, and the drop-down menu that you get when you right-click appears.

Ditto for resizing brush sides.

Is this the expected behavior?

I was expecting the right-click to be ignored.

user81

26.07.2010 17:23

  ~0003148

This is till happening with 1.4.0, when I get the time I will build a very small test map so I can pin down exactly when/where it does it.

user81

02.02.2012 00:45

  ~0004288

This is still happening with 1.7.1
grayman

grayman

02.02.2012 01:48

administrator   ~0004290

Confirmed. The actions in my previous note are still happening.

user81

11.01.2013 09:37

  ~0004995

This is still happening in the latest version 1.7.3

user81

09.03.2014 17:53

  ~0006425

Still happening in 1.8.1

user81

04.01.2015 14:45

  ~0007299

Last edited: 04.01.2015 14:48

View 2 revisions

This is happening in 2.0.2 and its worse than ever.

1. shift LMB to select an item, eg a light entity
2. while holding the LMB drag the entity to a new location/
3. let go of the LMB and the entity snaps back to its original location.

greebo

greebo

05.01.2015 09:49

administrator   ~0007303

This was caused by the DeferredMouseMotion callback pending in the background, kicking in later, when the manipulation phase already started. It can be reproduced by moving the mouse and "on the go" left-clicking the object to drag it around. As soon as the mouse cursor stops for a little moment the idle callback kicks in and sends stale coordinates to the XYWnd's mouse motion handler.
greebo

greebo

05.01.2015 10:18

administrator   ~0007304

Removed the DeferredMouseMotion handler from both CamWnd and XYWnd.

Issue History

Date Modified Username Field Change
09.06.2010 11:03 user81 New Issue
10.06.2010 15:58 greebo Project The Dark Mod => DarkRadiant
10.06.2010 16:09 greebo Note Added: 0003053
10.06.2010 16:09 greebo Status new => feedback
11.06.2010 12:16 user81 Note Added: 0003061
11.06.2010 12:16 user81 Status feedback => new
26.06.2010 13:19 grayman Note Added: 0003097
27.06.2010 03:54 greebo Note Added: 0003098
27.06.2010 03:54 greebo Status new => confirmed
27.06.2010 05:09 greebo Status confirmed => assigned
27.06.2010 05:09 greebo Assigned To => greebo
27.06.2010 05:09 greebo Status assigned => resolved
27.06.2010 05:09 greebo Fixed in Version => 1.3.3
27.06.2010 05:09 greebo Resolution open => fixed
27.06.2010 05:10 greebo Category Mapping => Design/Coding
27.06.2010 05:10 greebo Product Version TDM 1.02 => 1.3.2
27.06.2010 05:10 greebo Target Version => 1.4.0
27.06.2010 08:43 user81 Note Added: 0003099
06.07.2010 06:20 greebo Fixed in Version 1.3.3 => 1.4.0
18.07.2010 17:35 user81 Note Added: 0003131
19.07.2010 14:10 grayman Note Added: 0003137
26.07.2010 17:23 user81 Note Added: 0003148
26.07.2010 17:23 user81 Status resolved => assigned
26.07.2010 17:23 user81 Resolution fixed => reopened
06.08.2010 13:12 user81 Status assigned => confirmed
02.02.2012 00:45 user81 Note Added: 0004288
02.02.2012 01:48 grayman Note Added: 0004290
24.03.2012 16:54 greebo Assigned To greebo =>
11.01.2013 09:36 user81 Note Edited: 0003099 View Revisions
11.01.2013 09:37 user81 Note Added: 0004995
09.03.2014 17:53 user81 Note Added: 0006425
09.03.2014 17:54 user81 OS Windows 7 x86 => Windows x64
09.03.2014 17:54 user81 OS Version => 8
09.03.2014 17:54 user81 Platform Qx9650/HD5870 => Corei5/GTX670
09.03.2014 17:54 user81 Product Version 1.3.2 => 1.8.0
04.01.2015 14:45 user81 Note Added: 0007299
04.01.2015 14:46 user81 Platform Corei5/GTX670 => Corei5/GTX970
04.01.2015 14:46 user81 Product Version 1.8.0 => 2.0.1
04.01.2015 14:46 user81 Fixed in Version 1.4.0 =>
04.01.2015 14:48 user81 Note Edited: 0007299 View Revisions
05.01.2015 09:46 greebo Assigned To => greebo
05.01.2015 09:46 greebo Status confirmed => assigned
05.01.2015 09:46 greebo Target Version 1.4.0 => 2.0.2
05.01.2015 09:49 greebo Note Added: 0007303
05.01.2015 10:18 greebo Note Added: 0007304
05.01.2015 10:18 greebo Status assigned => resolved
05.01.2015 10:18 greebo Fixed in Version => 2.0.2
05.01.2015 10:18 greebo Resolution reopened => fixed
07.07.2015 09:26 greebo Status resolved => closed