View Issue Details

IDProjectCategoryView StatusLast Update
0000233DarkRadiantGUIpublic01.05.2007 16:26
ReporterSneaksieDave Assigned Toorbweaver  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.0 
Summary0000233: Unnecessary scrollbars in entity inspector
DescriptionFor the longest time I thought I was imagining this or going crazy. Finally I decided to track it down. :)

Please open torchtest.map. Select the light of one of the candles, and size your entity inspector such that three property lines show (as shown in image on the left). Now, move the light out of the way, move the collision model out of the way, and select the candle model. Notice that now you only have two property lines (shown in image on the right). No prob, one of the properties is long enough that a horizontal scrollbar is needed.

However, deselect the candle and re-select the light. The scrollbar stays, even though it is not necessary. So now you're stuck with two property lines unless you resize the entity inspector up yet again. So the available space shrinks because the horizontal scrollbar isn't cleared.

May seem minor, but it's one of those UI issues that is really annoying for no good reason (maybe it's even a GTK bug - hope not).

Image: http://img223.imageshack.us/my.php?image=sizeszo3.jpg
TagsNo tags attached.

Activities

orbweaver

orbweaver

25.03.2007 11:09

developer   ~0000480

You're right -- if you resize the window the scrollbar disappears, but selecting another object alone does not clear it. I guess there is some event that needs to be manually triggered when a selection change is made so that the tree view checks for the scrollbar requirement.
orbweaver

orbweaver

25.03.2007 11:29

developer   ~0000481

Resolved in SVN.
SneaksieDave

SneaksieDave

26.03.2007 14:27

developer   ~0000504

Is it possible this didn't get merged for the 3/26 full drop? I have that one running, but I'm still getting the same effect (scrollbar appears for candlestick, and doesn't go away for e.g., a light)
orbweaver

orbweaver

14.04.2007 07:51

developer   ~0000570

Is this still a problem in later builds uploaded by greebo?
greebo

greebo

14.04.2007 08:34

administrator   ~0000573

I'll upload a new build right now to make sure, expect it on the FTP in 5 minutes. (10:35 CET :))

Issue History

Date Modified Username Field Change
25.03.2007 03:44 SneaksieDave New Issue
25.03.2007 07:13 greebo Status new => acknowledged
25.03.2007 11:09 orbweaver Note Added: 0000480
25.03.2007 11:09 orbweaver Status acknowledged => confirmed
25.03.2007 11:28 orbweaver Status confirmed => assigned
25.03.2007 11:28 orbweaver Assigned To => orbweaver
25.03.2007 11:29 orbweaver Status assigned => resolved
25.03.2007 11:29 orbweaver Fixed in Version => latest SVN
25.03.2007 11:29 orbweaver Resolution open => fixed
25.03.2007 11:29 orbweaver Note Added: 0000481
26.03.2007 14:27 SneaksieDave Status resolved => feedback
26.03.2007 14:27 SneaksieDave Resolution fixed => reopened
26.03.2007 14:27 SneaksieDave Note Added: 0000504
14.04.2007 07:51 orbweaver Note Added: 0000570
14.04.2007 08:34 greebo Note Added: 0000573
01.05.2007 16:26 SneaksieDave Status feedback => closed
01.05.2007 16:26 SneaksieDave Resolution reopened => fixed