View Issue Details

IDProjectCategoryView StatusLast Update
0002341The Dark ModCodingpublic09.10.2017 20:57
ReporterSpringheel Assigned Tograyman  
PriorityhighSeveritynormalReproducibilitysometimes
Status closedResolutionfixed 
Product VersionTDM 1.02 
Target VersionTDM 1.03Fixed in VersionTDM 1.03 
Summary0002341: "No_dups" not working for vocal barks
Description2. AI repeating the same vocal bark

This issue seems to come and go. But I've definitely had a single AI hunting for me, repeating the same search bark two or three times in succession. Often it seems like there are only two different barks used during the entire search, even though each character has at least six to choose from (sometimes more). I've felt like this has happened sometimes with idle barks as well, but not always.

Every vocal soundshader has "no_dups" on it, so theoretically AI should never say the same line twice in a row. Yet they frequently do. Nothing slices away at your suspension of disbelief like hearing the AI repeat the exact same phrase over and over like a robot.
TagsNo tags attached.

Relationships

related to 0002400 feedback Multiple-AI animations and barks can become synchronized 

Activities

Springheel

Springheel

22.08.2010 14:41

administrator   ~0003177

Orbweaver: I've noticed no_dups failing to work with footsteps sounds as well; on my system I have experienced "machine-gun footsteps" several times, even though this should be prevented.
grayman

grayman

21.10.2010 01:39

administrator   ~0003253

Last edited: 14.11.2010 23:51

View 3 revisions

Source changes:

1. Made changes to entity.cpp, entity.h, and player.cpp to provide our own 'no_dups' handling since Doom3's appears to have a bug in it.
2. Commented out 'no_dups' wherever it appeared in *.sndshd files defining voices and footsteps. We can't turn off 'no_dups' in the code before
we hand the sound to the engine, so it has to be turned off at the source. (There's a comment in the code that you can override shader flags,
but this doesn't work for SSF_NO_DUPS because overriding flags are OR'ed into the shader flags. Can't turn a bit off using OR.)

Testing:

1. Extensive testing with guard and player footstep sequences on various materials, showing the fix to work. Also checked ladder and chain climbing.
2. Extensive testing with AI barks.

Caveat:

Lots of inconsistencies exist among the sound shaders wrt the use of 'no_dups'. I.e. one builder's voice set might have 'no_dups' set everywhere it should be
set, and another builder's set might not. Anyone adding 'no_dups' to shaders they think need them might not catch that we don't need to set 'no_dups' any more
for voices and steps. Or someone adding a new AI might include 'no_dups' in new sound shaders. This could lead to duplicate barks or steps.
There's no way to control this, so we'll just have to respond to complaints if anyone notices.

File changes:

rev 4261:

entity.cpp (& rev 4266)
entity.h
player.cpp

rev 11146:

sound\tdm_ai_animal_horse.sndshd
sound\tdm_ai_animal_rat.sndshd
sound\tdm_ai_builder2.sndshd
sound\tdm_ai_builder3.sndshd
sound\tdm_ai_builder4.sndshd
sound\tdm_ai_builder5.sndshd
sound\tdm_ai_generic_idles.sndshd
sound\tdm_ai_grumbler.sndshd
sound\tdm_ai_jack.sndshd
sound\tdm_ai_lord.sndshd
sound\tdm_ai_monster_belcher.sndshd
sound\tdm_ai_monster_werebeast.sndshd
sound\tdm_ai_pro.sndshd
sound\tdm_ai_simpleton.sndshd
sound\tdm_ai_spider.sndshd
sound\tdm_ai_steambot.sndshd
sound\tdm_ai_thug.sndshd
sound\tdm_ai_undead_revenant.sndshd
sound\tdm_ai_undead_zombie.sndshd
sound\tdm_belcher_sfx_movement.sndshd
sound\tdm_player.sndshd

Issue History

Date Modified Username Field Change
22.08.2010 02:13 Springheel New Issue
22.08.2010 14:41 Springheel Note Added: 0003177
20.10.2010 20:15 grayman Assigned To => grayman
20.10.2010 20:15 grayman Reproducibility have not tried => sometimes
20.10.2010 20:15 grayman Status new => assigned
20.10.2010 20:15 grayman Product Version => TDM 1.02
20.10.2010 20:15 grayman Target Version => TDM 1.03
21.10.2010 01:39 grayman Note Added: 0003253
21.10.2010 01:39 grayman Status assigned => resolved
21.10.2010 01:39 grayman Resolution open => fixed
21.10.2010 01:39 grayman Fixed in Version => TDM 1.03
14.11.2010 23:50 grayman Note Edited: 0003253 View Revisions
14.11.2010 23:51 grayman Note Edited: 0003253 View Revisions
03.06.2011 03:59 greebo Status resolved => closed
09.10.2017 20:57 nbohr1more Relationship added related to 0002400