View Issue Details

IDProjectCategoryView StatusLast Update
0000240DarkRadiantMap Editingpublic15.06.2007 21:56
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.1 
Summary0000240: Geometry of unknown brush entities not shown
DescriptionTo see this happen, please open snow.map or rain.map.

A while ago, the doors used in these maps were "func_darkmod_door". That type of entity has since been changed to be an atdm:mover_door, but the map isn't yet updated, so this shows the problem perfectly.

As a result of the change, DR does not display the brushes anymore. I tried reverting the object to world, but that didn't work. The data is still in the map, but DR gives me no way to get to it, apparently. Then I tried changing the type, saving and reloading, but I still had no brush data.

In DoomEd, the doors are shown as normal brushes, and the unknown entity is just a generic cube at the origin. I can revert all of that to worldspawn and then declare the new type.
TagsNo tags attached.

Activities

greebo

greebo

28.03.2007 20:25

administrator   ~0000521

Last edited: 28.03.2007 20:25

Do you mean the two func_darkmod_doors in snow.map. These work fine for me.

http://img62.imageshack.us/img62/9852/funcdarkmoddooryj8.jpg

Or do you mean something different?

SneaksieDave

SneaksieDave

03.04.2007 01:55

developer   ~0000530

I think you might have the updated, fixed version I put up recently (I imagine that func_darkmod_door is the name, and not the class). If you would, try with this one:

http://208.49.149.118/thedarkmod/maps/unfixed.zip

For that one, I see this - a strange box as the entity, no brush geometry displayed (though it still exists in the map) - you can see the portal behind it:
http://img248.imageshack.us/my.php?image=nobrushdo1.jpg

That was when it was still a func_darkmod_door type. Oddly though, I tried something just now in re-testing this. I made three brushes into a func_door, and then turned it into a func_blah (to see how it handles unknown classes). On reload, although the class was of course unknown, the brush geometry stayed.... (??) Though I did note that when I saved, the brushes seemed to momentarily vanish and go back to the origin.

Whatever, I'm not sure what's going on. :-/ For whatever reason, when I open the old version of the map, I can't see the window geometry.
greebo

greebo

03.04.2007 07:00

administrator   ~0000531

The short flickering of brushes is ok, this is performed to save child brushes of func_statics relative to their origin (the origin gets substracted from all children, then the map is saved, after that the origin is added again, hence the flickering).

I'll sure have a look at the other map.
greebo

greebo

13.04.2007 17:03

administrator   ~0000568

This seems to be a special issue, because there are two occurrences of "func_darkmod_door" in "snow.map". The first occurrence (entity 3) has no child brushes, the second (entity 19) does have child brushes.

When the map file is parsed and the unknown entity is encountered, DarkRadiant assumes that this is a generic entity (because entity 3 without brushes is encountered first) and creates an entity class without brushes. By the time the second occurrence (entity 19) is found, the entity class is already created as generic one, hence the brushes are discarded.

I could try to change the default setting for unknown entities to non-generic (so that it can hold child brushes), but I don't know if that causes other problems.

Further investigations necessary. :)
greebo

greebo

14.04.2007 08:33

administrator   ~0000572

I changed the default behaviour of the entity class manager a bit such that unknown entities are forcedly created as "brush-containing" entities.

All entity classes from the .def files are parsed before the map loading process so this should only affect the handling of unknown entities encountered during map load.
SneaksieDave

SneaksieDave

15.06.2007 21:56

developer   ~0000686

Looking good.

Issue History

Date Modified Username Field Change
26.03.2007 17:35 SneaksieDave New Issue
26.03.2007 18:33 greebo Status new => acknowledged
28.03.2007 20:25 greebo Note Added: 0000521
28.03.2007 20:25 greebo Assigned To => SneaksieDave
28.03.2007 20:25 greebo Status acknowledged => feedback
28.03.2007 20:25 greebo Note Edited: 0000521
03.04.2007 01:55 SneaksieDave Note Added: 0000530
03.04.2007 07:00 greebo Note Added: 0000531
03.04.2007 07:00 greebo Status feedback => assigned
03.04.2007 07:00 greebo Assigned To SneaksieDave => greebo
13.04.2007 17:03 greebo Note Added: 0000568
14.04.2007 08:33 greebo Status assigned => resolved
14.04.2007 08:33 greebo Fixed in Version => latest SVN
14.04.2007 08:33 greebo Resolution open => fixed
14.04.2007 08:33 greebo Note Added: 0000572
15.06.2007 21:56 SneaksieDave Status resolved => closed
15.06.2007 21:56 SneaksieDave Note Added: 0000686
15.06.2007 21:56 SneaksieDave Fixed in Version 0.9.0 => 0.9.1