View Issue Details

IDProjectCategoryView StatusLast Update
0002413The Dark ModCodingpublic03.06.2011 03:59
Reportertels Assigned Totels  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionTDM 1.02 
Target VersionTDM 1.03Fixed in VersionTDM 1.03 
Summary0002413: Broken CPUID on Linux
DescriptionOn Linux, it seems D3 does not properly recognize the CPU (CPUID seems to return always 0), so the capabilities (SSE, SSE2 etc) are not recognized. Therefore, no SIMD provider can be chosen.
Additional Informationhttp://modetwo.net/darkmod/index.php?/topic/11828-simd-module-and-cpuid-on-linux/page__view__findpost__p__234725
TagsNo tags attached.

Relationships

parent of 0002427 resolvedstgatilov Broken SIMD Support on Linux 

Activities

tels

tels

02.11.2010 06:25

reporter   ~0003276

sys/sys_public.h contains the definitions of the CPU flags, and idlib/math/simd.cpp and idlib/math/simd.h the implementation.
tels

tels

15.11.2010 21:56

reporter   ~0003295

Added experimental inline asm code that generates the proper cpuid_t value (needs a bit of work sep. AMD from Intel and checking for 3DNow! for AMD). Not enough to get it working because we also need to implement the SIMD providers for linux, but it is a start.
tels

tels

19.11.2010 07:55

reporter   ~0003301

Resolved with revisions 0004277 and 0004278.

Issue History

Date Modified Username Field Change
02.11.2010 06:24 tels New Issue
02.11.2010 06:25 tels Note Added: 0003276
02.11.2010 06:26 tels Product Version => TDM 1.02
02.11.2010 06:26 tels Description Updated View Revisions
15.11.2010 20:43 tels Assigned To => tels
15.11.2010 20:43 tels Status new => assigned
15.11.2010 21:56 tels Note Added: 0003295
19.11.2010 07:44 tels Relationship added parent of 0002427
19.11.2010 07:45 tels Summary Broken SIMD support on Linux => Broken CPUID on Linux
19.11.2010 07:45 tels Description Updated View Revisions
19.11.2010 07:45 tels Steps to Reproduce Updated View Revisions
19.11.2010 07:45 tels Additional Information Updated View Revisions
19.11.2010 07:46 tels Fixed in Version => TDM 1.03
19.11.2010 07:46 tels Target Version => TDM 1.03
19.11.2010 07:55 tels Note Added: 0003301
19.11.2010 07:55 tels Status assigned => resolved
19.11.2010 07:55 tels Resolution open => fixed
03.06.2011 03:59 greebo Status resolved => closed