View Issue Details

IDProjectCategoryView StatusLast Update
0002456The Dark ModCodingpublic10.10.2017 03:56
Reportertels Assigned ToSerpentine  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionunable to reproduce 
Product VersionTDM 1.07 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0002456: Make TDM friendly with ATI Catalyst AI
DescriptionAt the moment a number of issues arise from Cat AI. While this was impossible to cleanly fix in the past; it should now be addressable.

Hopefully a clean solution can be found.
Additional InformationThis should not be fixed by temporarily changing driver settings/registry or using elaborate workarounds (tho not ruling out adjusting the engine, if there is a credible reason).
TagsNo tags attached.

Activities

Serpentine

Serpentine

17.01.2012 22:51

developer   ~0004256

Started talking to my AMD developer relations guy again - waiting on them for feedback about how to best approach this (either to correct it engine side or to try talking nicely to the driver).
nbohr1more

nbohr1more

18.01.2012 01:10

developer   ~0004259

To my knowledge, the simple act of renaming the Doom 3 executable resolves problems with Catalyst AI as the profiler does not know to assign the erroneous optimizations to the new executable. If you allow the new TDM build to be renamed to DarkAthena.exe you will resolve the artifacts and allow the mod to run in crossfire mode.

That said, ATI's driver's are very sensitive to ARB code order issues. If you switched to one of the GLSL forks you could let the Driver chose the ARB assembly rather than trial and error...

Raynorpat's GLSL with StencilOpSeparate for the Carmack Reverse:

http://git.iodoom.org/~raynorpat/iodoom3/raynorpats-glsl_iodoom3

LogicalError's GLSL with enhanced Speculars:

https://github.com/LogicalError/doom3.gpl

Plus you would gain the performance optimizations for GLSL rather than hoping that your ARB code order is mapped well to the hardware...
Serpentine

Serpentine

18.01.2012 19:22

developer   ~0004261

Renaming the exe : no
Using GLSL : not within my level of care or scope of this ticket

Resolving this with the least changes, using the correct method: yes.
nbohr1more

nbohr1more

19.01.2012 01:31

developer   ~0004262

To clarify...

Version 1.08 wont ship as "darkmod.exe" or "thedarkmod.exe" but instead it will be shipped as "Doom3.exe" ?

Or are you claiming that renaming the executable no longer resolves these problems?

Or are you saying that end-users wont be allowed to rename "darkmod.exe" to "darkathena.exe" for some reason (hard coded executable reference)?

Once more ambitious engine changes are adopted, utilizing the Doom 3 profile in Catalyst AI will be pointless anyway wont it?

If anything, the Brink and RAGE profiles suck too... you'd want to use the Chronicles of Riddick Dark Athena profile for anything modern in OpenGL until some big studio releases another (better supported) title... And maybe emulate some of their render methods...

Though it would be cool if ATI Dev-Rel would look at the post-process shader and offer an alternate method. (Mostly for historical purposes. The "upside-down" issue has plagued Doom 3 Bloom mods for ages... it would be cool to see why.)
greebo

greebo

19.01.2012 07:12

administrator   ~0004263

The engine that ships with TDM will be called TheDarkMod.exe.
nbohr1more

nbohr1more

10.10.2017 03:56

developer   ~0009444

1) ATI is now AMD
2) Catalyst AI doesn't really exist anymore
3) Recent AMD drivers don't really cause this problem anymore
4) TDM ships as TheDarkMod.exe
5) 2.06 has a GLSL render backend

Issue History

Date Modified Username Field Change
04.12.2010 11:48 tels New Issue
17.01.2012 22:50 Serpentine Assigned To => Serpentine
17.01.2012 22:50 Serpentine Status new => assigned
17.01.2012 22:51 Serpentine Note Added: 0004256
17.01.2012 22:51 Serpentine Status assigned => acknowledged
17.01.2012 22:54 Serpentine Summary Add automatic switching of ATI catalyst => Make TDM friendly with ATI Catalyst AI
17.01.2012 22:54 Serpentine Description Updated View Revisions
17.01.2012 22:54 Serpentine Steps to Reproduce Updated View Revisions
17.01.2012 22:54 Serpentine Additional Information Updated View Revisions
18.01.2012 01:10 nbohr1more Note Added: 0004259
18.01.2012 19:22 Serpentine Note Added: 0004261
19.01.2012 01:31 nbohr1more Note Added: 0004262
19.01.2012 07:12 greebo Note Added: 0004263
10.10.2017 03:55 nbohr1more Status acknowledged => resolved
10.10.2017 03:55 nbohr1more Resolution open => unable to reproduce
10.10.2017 03:55 nbohr1more Product Version => TDM 1.07
10.10.2017 03:55 nbohr1more Fixed in Version => TDM 2.06
10.10.2017 03:55 nbohr1more Target Version => TDM 2.06
10.10.2017 03:56 nbohr1more Note Added: 0009444