View Issue Details

IDProjectCategoryView StatusLast Update
0002488DarkRadiantModelspublic31.07.2011 04:44
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.4.0 
Target Version1.5.0Fixed in Version1.5.0 
Summary0002488: Crash when opening LWO when sorting textures internally
DescriptionThe attached model makes DarkRadiant crash reproducibly.
TagsNo tags attached.

Activities

greebo

greebo

18.12.2010 04:12

administrator  

deer_skull_staff.lwo (69,152 bytes)
Springheel

Springheel

18.12.2010 04:21

administrator   ~0003390

It's not just missing shaders...that model crashes frequently even when it points at shaders that do exist.
greebo

greebo

18.12.2010 08:25

administrator   ~0003391

There was a problem with sorting the lightwave textures into a surface's texture list, the textures had NULL values where the strings were expected, and obviously DarkRadiant was not prepared for that. It's possible that we never had that combination of multiple LW textures per surface and missing ordinal strings.

Anyway, it's fixed now.

Issue History

Date Modified Username Field Change
18.12.2010 04:12 greebo New Issue
18.12.2010 04:12 greebo File Added: deer_skull_staff.lwo
18.12.2010 04:12 greebo Assigned To => greebo
18.12.2010 04:12 greebo Status new => assigned
18.12.2010 04:21 Springheel Note Added: 0003390
18.12.2010 07:53 greebo Summary Crash when opening LWO with empty/missing shaders => Crash when opening LWO when sorting textures internally
18.12.2010 08:23 greebo Status assigned => resolved
18.12.2010 08:23 greebo Fixed in Version => 1.5.0
18.12.2010 08:23 greebo Resolution open => fixed
18.12.2010 08:23 greebo Product Version 1.5.0 => 1.4.0
18.12.2010 08:25 greebo Note Added: 0003391
31.07.2011 04:44 greebo Status resolved => closed