View Issue Details

IDProjectCategoryView StatusLast Update
0002491The Dark ModCodingpublic03.07.2021 09:11
ReporterFidcal Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityN/A
Status closedResolutionwon't fix 
Summary0002491: Consider method for mappers to change entity properties in-game
DescriptionIt would be useful if mappers could change more entity properties while the FM is running.

This post and thread relate....

http://forums.thedarkmod.com/topic/12032-more-dynamic-properties/#entry241045

I'll add a couple of suggested spawnargs later
TagsNo tags attached.

Relationships

related to 0003576 resolvedgrayman Player needs a type spawnarg 

Activities

Fidcal

Fidcal

21.12.2010 08:10

updater   ~0003394

Here are a couple of suggested spawnargs to test on:

used_by_added (or similar suffix)
speed
Fidcal

Fidcal

21.12.2010 08:12

updater   ~0003395

Could properties be removed? eg, bind

user81

28.03.2018 10:22

  ~0010231

@Greebo, can this be closed?
nbohr1more

nbohr1more

25.07.2018 20:36

developer   ~0010728

This is the current method:

http://forums.thedarkmod.com/topic/16412-setting-spawnargs-on-player/#entry350408

related thread:

http://forums.thedarkmod.com/topic/16414-player-impersonating-others/
stgatilov

stgatilov

03.07.2021 09:08

administrator   ~0014142

This is not right, because "spawnarg" as an argument for spawning an entity, it is not a properly of living entity.
Indeed, it is possible to add script events which will change the actual properties at the moment you call it, and that's the right way to proceed.

If you change spawnargs, the only proper way for the change to have effect is respawning the entity.
Of course, any information gathered during entity lifetime is lost (sometimes it is a problem, sometimes not).
This approach is used for hot reload, so that mappers can edit their map and apply changes in-game (0005316).
Even for this use case, it was never deemed perfectly reliable, and for gameplay changes it should never be used.
I tried to apply some spawnarg changes without respawning an entity, but it generates more problems that it solves, and only works for trivial properties like position/orientation.

Issue History

Date Modified Username Field Change
20.12.2010 12:00 Fidcal New Issue
20.12.2010 12:00 Fidcal Status new => assigned
20.12.2010 12:00 Fidcal Assigned To => Fidcal
21.12.2010 08:10 Fidcal Note Added: 0003394
21.12.2010 08:12 Fidcal Note Added: 0003395
21.12.2010 08:13 Fidcal Assigned To Fidcal => greebo
24.03.2012 16:55 greebo Assigned To greebo =>
24.03.2012 16:55 greebo Status assigned => acknowledged
28.03.2018 10:22 user81 Note Added: 0010231
25.07.2018 20:17 nbohr1more Description Updated View Revisions
25.07.2018 20:36 nbohr1more Note Added: 0010728
25.07.2018 20:37 nbohr1more Relationship added related to 0003576
03.07.2021 09:08 stgatilov Note Added: 0014142
03.07.2021 09:11 stgatilov Assigned To => stgatilov
03.07.2021 09:11 stgatilov Status acknowledged => assigned
03.07.2021 09:11 stgatilov Status assigned => closed
03.07.2021 09:11 stgatilov Resolution open => won't fix