View Issue Details

IDProjectCategoryView StatusLast Update
0002534DarkRadiantMap Editingpublic31.07.2011 04:43
Reportergrayman Assigned Togreebo  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWin32OSWindowsOS VersionXP
Product Version1.4.0 
Target Version1.5.0Fixed in Version1.5.0 
Summary0002534: Brushes created with 7 faces
DescriptionBrushes created with the "Make Room" button are given 7 faces.

I've tried this several times in different maps and always get 7 faces. I don't know if the original brush has anything unique about it. I marked the problem as "Always" but I haven't proven that it could be "Sometimes".
Steps To ReproduceOpen DR.

Don't open an existing map.

Create a 128x128x128 brush at the origin.

Texture it with caulk.

Set the grid size to 8.

Hit the "Make Room" button. The new brushes look fine.

Save the map.

Open the map file in a text editor.

All 6 newly-created brushes have 7 faces.
Additional InformationThe problem could be in the creation method.

It could also be in the way brushes are written to the *.map file.
TagsNo tags attached.

Activities

greebo

greebo

11.01.2011 14:33

administrator   ~0003436

It seems that the "Hollow" and "Make Room" algorithms are adding a seventh face, not yet looked into why this is.
greebo

greebo

11.01.2011 14:37

administrator   ~0003437

I'll mark this as minor as it seems that previous DR versions did that too and no maps seem to be negatively affected.
greebo

greebo

13.01.2011 13:49

administrator   ~0003449

Last edited: 13.01.2011 13:49

View 2 revisions

When I refactored the map exporter code, I omitted this line:

_brush.evaluateBRep(); // ensure b-rep is up-to-date, so that non-contributing faces can be identified.

I assume this is the reason for the non-contributing faces to show up in the map. In my opinion this was a workaround anyway and these faces should be removed when freezing the transformation.

rev: 5177 is the last one without this symptom.

greebo

greebo

13.01.2011 18:47

administrator   ~0003450

Fixed - empty or degenerate windings are not written to the mapfile anymore.

Issue History

Date Modified Username Field Change
11.01.2011 04:34 grayman New Issue
11.01.2011 04:34 grayman Status new => assigned
11.01.2011 04:34 grayman Assigned To => greebo
11.01.2011 14:33 greebo Note Added: 0003436
11.01.2011 14:37 greebo Note Added: 0003437
11.01.2011 14:37 greebo Assigned To greebo =>
11.01.2011 14:37 greebo Status assigned => confirmed
13.01.2011 13:49 greebo Note Added: 0003449
13.01.2011 13:49 greebo Note Edited: 0003449 View Revisions
13.01.2011 18:47 greebo Assigned To => greebo
13.01.2011 18:47 greebo Status confirmed => assigned
13.01.2011 18:47 greebo Target Version => 1.5.0
13.01.2011 18:47 greebo Note Added: 0003450
13.01.2011 18:47 greebo Status assigned => resolved
13.01.2011 18:47 greebo Fixed in Version => 1.5.0
13.01.2011 18:47 greebo Resolution open => fixed
31.07.2011 04:43 greebo Status resolved => closed