View Issue Details

IDProjectCategoryView StatusLast Update
0000258DarkRadiantMap Editingpublic01.05.2007 14:52
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.0 
Summary0000258: Paint whole brush (ctrl-alt-MMB) doesn't always work
DescriptionTexture whole brush shortcut doesn't work unless selected texture exists in already loaded list

-Open a new map, create two brushes
-In the Media tree, select a texture, and then ctrl-alt-MMB to texture one whole brush. It doesn't work...
-Use RMB Apply to Selection instead. That works.
-Now, MMB the newly textured brush to lift the same texture as before
-ctrl-alt-MMB the other brush. It textures properly

I think the reason this is happening is that ctrl-alt-MMB can only work for textures that are currently listed as active for the map, that is, those that appear on the Textures tab.
TagsNo tags attached.

Activities

greebo

greebo

08.04.2007 19:25

administrator   ~0000543

The reason is that merely selecting a shader name in the Media Browser doesn't do anything, especially not copying that shader into the ShaderClipboard, which is required for the shader being applicable by Ctrl-Alt-MMB.

The ShaderClipboard is the source of reference for MMB actions, not the Media Browser.

I could think of emitting an error if the ShaderClipboard is empty and the mapper tries to paste shaders. Would this help to avoid confusion?
SneaksieDave

SneaksieDave

09.04.2007 14:20

developer   ~0000556

Is it not possible (or not a good idea) to copy the selected texture in the Media tab to the ShaderClipboard, to alleviate the problem? Maybe that's too slow or taxing an operation?

This isn't a 'huge' problem, for sure, very small in fact, but I foresee people hitting it frequently.
greebo

greebo

09.04.2007 15:52

administrator   ~0000558

I think it is possible to save the shadername into the ShaderClipboard. I will have to take sure that a simple shader without source object doesn't cause any weird stuff, but I'll look into it.
greebo

greebo

13.04.2007 08:33

administrator   ~0000566

Resolved. Selecting a shader in the media browser copies the shader into the clipboard so that it can be used for MMB texturing.

Issue History

Date Modified Username Field Change
08.04.2007 17:52 SneaksieDave New Issue
08.04.2007 19:25 greebo Note Added: 0000543
08.04.2007 19:25 greebo Assigned To => SneaksieDave
08.04.2007 19:25 greebo Status new => feedback
09.04.2007 14:20 SneaksieDave Note Added: 0000556
09.04.2007 15:52 greebo Note Added: 0000558
09.04.2007 15:52 greebo Status feedback => assigned
09.04.2007 15:52 greebo Assigned To SneaksieDave => greebo
13.04.2007 08:33 greebo Status assigned => resolved
13.04.2007 08:33 greebo Fixed in Version => latest SVN
13.04.2007 08:33 greebo Resolution open => fixed
13.04.2007 08:33 greebo Note Added: 0000566
01.05.2007 14:52 SneaksieDave Status resolved => closed