View Issue Details

IDProjectCategoryView StatusLast Update
0000026The Dark ModCodingpublic06.11.2007 03:02
ReporterSneaksieDave Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Summary0000026: Floating up upon AI contact
Descriptionsource:
http://modetwo.net/darkmod/index.php?s=&showtopic=5108&view=findpost&p=94358

Again I wasn't sure what category to put this under. I guess 'coding' could be considered to cover collision, physics, etc?

---
Okay, I separated this out from Dram's entry specifcally about trees: http://modetwo.net/darkmod/index.php?showtopic=4882

In it, I made a comment about the AI, and Ishtvan responded.

I don't know if this is new or was perhaps always the case, but I just did the following - in a map with only ambient light level of 5 (fully black to AI, barely see for us), I stepped twice to get a citywatch to come investigating near me. His audio, visual, and tactile senses are all enabled as default. When he bumps me, he of course realizes I'm there and starts to attack. However! I float up about 5 feet into the air before falling to the ground in front of him. Whether it's still about falling up the weapon or not, I don't know. Possibly, because the falling upward starts when he goes for the sword, but not before it. This is fully reproducable, and since it arises from being bumped in the dark by a fully sensing AI, it won't be rare afterall.
TagsNo tags attached.

Activities

SneaksieDave

SneaksieDave

06.11.2007 03:02

developer   ~0000829

This seems to be okay; I repro the situation, and the most I've ever been bumped up before the AI started whomping on me was about 3 inches - not 5 feet.

Issue History

Date Modified Username Field Change
23.01.2007 19:54 SneaksieDave New Issue
05.11.2007 03:41 Dram Status new => resolved
06.11.2007 03:02 SneaksieDave Status resolved => closed
06.11.2007 03:02 SneaksieDave Note Added: 0000829
06.11.2007 03:02 SneaksieDave Resolution open => fixed