View Issue Details

IDProjectCategoryView StatusLast Update
0002600The Dark ModAIpublic17.02.2012 16:56
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Fixed in VersionTDM 1.08 
Summary0002600: AI don't care arrow is sticking out of them
DescriptionWhen you first shoot an AI with an arrow, you frequently get the comment, "Who left a weapon lying around here" rather than a pain sound.

Probably one of the most ridiculous reactions in TDM, AI seem to care more that there's a weapon left out than they do that it's sticking out of THEM.

"Weapon" barks generally sound ridiculous when applied to arrows anyway, but they certainly should be overridden by pain.
TagsNo tags attached.




03.02.2011 16:42

reporter   ~0003548


I may be able to fix this one. Let me take a look. Cheers.


07.02.2011 15:59

reporter   ~0003571


Pretty sure I have found a resolution to this.

Just need to get the code to build now, so I can test it:


08.02.2011 06:09

administrator   ~0003575

I thought the code had been changed a while back to not let arrows stick out of live AI. Only dead AI.


08.02.2011 22:31

administrator   ~0003576

Sorry, bad phrasing. The arrow isn't actually sticking out of them. Perhaps they're seeing the arrow before it hits them, causing the "weapon" bark to start? I would think "pain" would override most other barks, though.


09.02.2011 11:45

reporter   ~0003579


The script tdm_weapon_arrow_result_base.script has code to prevent the arrow result being spawned and bound to the AI.

What I (think I) observed it the AI issuing a weapon out of place sound as it sees the arrow at some point just before or on impact with the AI.

One thing that may be solve it, is to add an 'is at rest' property for entities, that queries the entities physics state and only allow AI to notice items that are according to physics at a state of rest.

Can finally build the code now Greebo sorted out a set of boost libs so can experiment and test further to see if this actually is what is happening.



14.02.2011 10:04

reporter   ~0003587

Last edited: 14.02.2011 10:05

View 2 revisions


Have been using FM Thef's Den to try and replicate the issue as it there is a guard just round the corner from the start and it is very small and fast to load ad try stuff.

However, I cannot replicate the problem described at all.

Have also thoroughly looked through the arrow scripts and SDK code and it all looks water tight to prevent the issue you describe.

Can you provide exact instructions on how to replicate the issue? I have tried body, head, near miss all sorts.

I can only conclude that I deluded myself that I replicated the issue in the first place. Maybe I was being retarded and checking against 1.0.2 not 1.0.3?




14.02.2011 22:21

administrator   ~0003588

It's equally possible that there was some specific factor at play, like being on the same team as the AI or having notarget on, both things that are frequently true when I'm testing.


30.10.2011 20:03

administrator   ~0004113

Is this still an issue?

Recent changes for 0002801 should fix this problem.

The only arrow that's visible in flight is the fire arrow.


17.02.2012 16:56

administrator   ~0004337

I haven't noticed this for some time so I'll mark it resolved for now.

Issue History

Date Modified Username Field Change
01.02.2011 15:18 Springheel New Issue
03.02.2011 16:42 solarsplace Note Added: 0003548
07.02.2011 15:59 solarsplace Note Added: 0003571
08.02.2011 06:09 grayman Note Added: 0003575
08.02.2011 22:31 Springheel Note Added: 0003576
09.02.2011 11:45 solarsplace Note Added: 0003579
14.02.2011 10:04 solarsplace Note Added: 0003587
14.02.2011 10:05 solarsplace Note Edited: 0003587 View Revisions
14.02.2011 22:21 Springheel Note Added: 0003588
30.10.2011 20:03 grayman Note Added: 0004113
30.10.2011 20:55 Springheel Assigned To => Springheel
30.10.2011 20:55 Springheel Status new => feedback
17.02.2012 16:56 Springheel Note Added: 0004337
17.02.2012 16:56 Springheel Status feedback => assigned
17.02.2012 16:56 Springheel Status assigned => resolved
17.02.2012 16:56 Springheel Fixed in Version => TDM 1.08
17.02.2012 16:56 Springheel Resolution open => fixed