View Issue Details

IDProjectCategoryView StatusLast Update
0002801The Dark ModCodingpublic18.10.2011 21:27
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionTDM 1.06 
Target VersionTDM 1.07Fixed in VersionTDM 1.07 
Summary0002801: AI play "weapon" bark when shot by arrow
DescriptionI was watching a friend play a mission tonight, and he was sniping at an AI from the top of a wall. The AI couldn't see him, and every time he got shot by an arrow, he kept saying, "What's a weapon doing around here?" It sounded ridiculous.

I've heard AI react to arrows with weapon barks while being shot at, but I thought it was because I was set to notarget. Apparently not.

This is quite goofy and immersion breaking when it happens.
TagsNo tags attached.

Activities

Springheel

Springheel

11.07.2011 01:25

administrator   ~0003918

Last edited: 11.07.2011 01:26

View 2 revisions

I think that AI who are being shot at should not make ANY barks about other stimulus. If you're taking fire from an unknown sniper, you're not going to be commenting about weapons, or missing items, or even a body. You're going to be looking for who is shooting at you and/or taking cover.

Perhaps some kind of timer could track how long it's been since an AI was hurt?

grayman

grayman

16.10.2011 17:31

administrator   ~0004075

Remove the projectile_result for an arrow that isn’t going to stick into the AI (not allowed when he’s alive). This was sending a “suspicious” stim to nearby AI.

Raise the AI’s alert level. This was being done by the projectile_result stim, but that was the wrong way to do it. Now that the correct way is being used (it was already there, but wasn’t being used for arrows), the AI has a good chance of turning toward the player and starting his search halfway to the player.

The alert level is set so that all other alerts other than spotting an enemy will be ignored until the alert level comes down. Audio alerts weren’t following this rule, but they are now.

rev. 4995:

SearchingState.cpp
State.cpp

Rev. 12306:

tdm_weapon_arrow_result_base.script

Issue History

Date Modified Username Field Change
09.07.2011 04:05 Springheel New Issue
11.07.2011 01:25 Springheel Note Added: 0003918
11.07.2011 01:26 Springheel Note Edited: 0003918 View Revisions
16.10.2011 17:31 grayman Note Added: 0004075
16.10.2011 17:31 grayman Status new => resolved
16.10.2011 17:31 grayman Resolution open => fixed
16.10.2011 17:31 grayman Product Version TDM 1.07 => TDM 1.06
16.10.2011 17:31 grayman Fixed in Version => TDM 1.07
16.10.2011 17:31 grayman Target Version => TDM 1.07
18.10.2011 21:27 grayman Assigned To => grayman