View Issue Details

IDProjectCategoryView StatusLast Update
0000263DarkRadiantMap Editingpublic15.06.2007 22:21
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.1 
Summary0000263: Renaming func_* breaks it
DescriptionI'm not sure the extent of the breakage, so I'll just call it that. :)
This is another that I assume/hope will go away with the selection/grouping overhaul, but let's track it so as not to lose it.

-Create a brush and convert it to func_static.
-Duplicate it.
-With the duplicate selected, change the "name" to something else.

It seems to lose the geometry, and become repositioned elsewhere. I also tried tabbing before renaming but that wasn't noticably better in outcome.
TagsNo tags attached.

Activities

greebo

greebo

08.04.2007 19:30

administrator   ~0000546

This is because the name and model key MUST be the same for such entities, otherwise they are considered actual models (those using actual .lwo or .ase files). There is no clean distinction between model entities and ordinary entities, that's why this behaviour seems ugly.

What is the intention of the rename operation? What did you want to achieve?
orbweaver

orbweaver

08.04.2007 20:50

developer   ~0000548

Last edited: 08.04.2007 20:52

I could see why mappers might want a proper name, such as "balcony_stairs" rather than "func_static_234".

I guess some sort of "name changed callback" would be needed to automatically update the model key as well. This is kind of ugly, because normally keys should be considered orthogonal, but in this case the original requirement is ugly so a workaround is the only real solution.

greebo

greebo

08.04.2007 20:55

administrator   ~0000551

Then we'll have to make sure that the model key is locked to have the same value as the name if the latter is renamed. I'll look into that when I have time. :)
greebo

greebo

12.04.2007 19:30

administrator   ~0000563

Last edited: 12.04.2007 19:30

I just fiddled around with this and it seems to be non-trivial. Updating the "model" spawnarg when the "name" value is changed triggers a couple of updates and in the end a bunch of "assertions: keyobservers still attached" messages appear on shutdown.

This is probably because during map load the entity key values are set and "name" key changes trigger this update as well.

I could of course think of some nasty hacks to disable the "model" updating during map load, but I won't do this. Maybe we can think of another way.

greebo

greebo

09.05.2007 14:14

administrator   ~0000638

Rename operations of func_YYY entities is caught now and the "model" key is adapted accordingly.
SneaksieDave

SneaksieDave

15.06.2007 22:21

developer   ~0000687

That's all very scary sounding. But it seems to work. :)

Issue History

Date Modified Username Field Change
08.04.2007 17:55 SneaksieDave New Issue
08.04.2007 19:30 greebo Note Added: 0000546
08.04.2007 19:30 greebo Status new => acknowledged
08.04.2007 20:50 orbweaver Note Added: 0000548
08.04.2007 20:52 orbweaver Note Edited: 0000548
08.04.2007 20:55 greebo Note Added: 0000551
08.04.2007 20:55 greebo Assigned To => greebo
08.04.2007 20:55 greebo Status acknowledged => assigned
12.04.2007 19:30 greebo Note Added: 0000563
12.04.2007 19:30 greebo Note Edited: 0000563
09.05.2007 14:14 greebo Status assigned => resolved
09.05.2007 14:14 greebo Fixed in Version => latest SVN
09.05.2007 14:14 greebo Resolution open => fixed
09.05.2007 14:14 greebo Note Added: 0000638
15.06.2007 22:21 SneaksieDave Status resolved => closed
15.06.2007 22:21 SneaksieDave Note Added: 0000687