View Issue Details

IDProjectCategoryView StatusLast Update
0002678The Dark ModPhysicspublic14.10.2015 18:15
Reportertels Assigned ToSteveL  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product VersionTDM 1.04 
Summary0002678: nodraw skinned surfaces are still active for collision detection
DescriptionIf you switch the skin on a model to one that hides certain surfaces with "nodraw", the hidden surfaces are still active and use the same material as before. For instance, use a wooden door without the metal hinges, and the player is not able to shoot an arrow into these parts of the door, as the invisible hinges are still active in the CM.
TagsNo tags attached.

Relationships

duplicate of 0004232 resolvedSteveL skins do not change collision data 
related to 0002297 new Sidedness of material sticks to skin 

Activities

tels

tels

07.03.2011 06:42

developer  

door_hinges.jpg (98,483 bytes)   
door_hinges.jpg (98,483 bytes)   
grayman

grayman

07.03.2011 21:03

administrator   ~0003723

Stupid question (since I ran into the "CM/materials change" problem a couple days ago):

Did you delete and recreate the *.cm file after switching the hinge skins?

Maybe it's irrelevant for models, I don't know.
Springheel

Springheel

07.03.2011 21:48

administrator   ~0003724

Strange. This shouldn't happen.
tels

tels

15.03.2011 18:05

developer   ~0003757

Last edited: 15.03.2011 18:07

View 2 revisions

The screenshot is from Knighton's Manor v1.1, and I definitely did not use the original CM file. Also, the CM file is (IMO) rather irrelevant, since the skin change (!) happens after model load. E.g. even if the CM somehow would contain the right information, ifyou switched the skin, the door would be broken again.

@Springheel: Actually, there is no code in the engine to rebuild the visual model nor its corrosponding CM when you change the skin, so this is actually whats is expected, it is just - an unexpected side-effect.

SteveL

SteveL

14.10.2015 18:15

developer   ~0007866

This will be fixed with 0004232

Issue History

Date Modified Username Field Change
07.03.2011 06:40 tels New Issue
07.03.2011 06:42 tels File Added: door_hinges.jpg
07.03.2011 21:03 grayman Note Added: 0003723
07.03.2011 21:48 Springheel Note Added: 0003724
15.03.2011 18:05 tels Note Added: 0003757
15.03.2011 18:06 tels Relationship added related to 0002297
15.03.2011 18:07 tels Note Edited: 0003757 View Revisions
12.10.2015 00:19 SteveL Relationship added related to 0004232
14.10.2015 18:09 SteveL Relationship replaced duplicate of 0004232
14.10.2015 18:15 SteveL Note Added: 0007866
14.10.2015 18:15 SteveL Status new => closed
14.10.2015 18:15 SteveL Assigned To => SteveL
14.10.2015 18:15 SteveL Resolution open => fixed