View Issue Details

IDProjectCategoryView StatusLast Update
0002782The Dark ModGUIpublic23.06.2011 11:12
Reportertels Assigned Totels  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionTDM 1.06 
Target VersionTDM 1.07Fixed in VersionTDM 1.07 
Summary0002782: Add a way to switch the language in the menu
DescriptionTechnically, we just need an entry that switches "sys_lang" to "german", "italian" etc. Probably needs a restart after that, but then it should work (at least for the things that are already translated).
Additional InformationUnfortunately, the Gameplay section in the Settings menu has no more space, and there is no "General" settings tab. So we probably need to split the "Gameplay" section up into "Gameplay" and "Interface".
TagsNo tags attached.

Relationships

child of 0002779 confirmed Translate the menu and HUD into different languages 

Activities

tels

tels

19.06.2011 10:57

reporter   ~0003883

A working language selector has been added to the menu, switching the language needs a D3 restart, but then it works.

We probably need to move the entry from the "Video" section to a new "Menu And HUD" section, tho.
tels

tels

23.06.2011 11:12

reporter   ~0003898

Seems to be working, even if the menu location is not the best. But moving it to the gameplay section needs to rework that entire section by splitting it up, and this is a bit too much work for such a trivial thing. So resolving this for now.

Issue History

Date Modified Username Field Change
19.06.2011 10:35 tels New Issue
19.06.2011 10:35 tels Status new => assigned
19.06.2011 10:35 tels Assigned To => tels
19.06.2011 10:38 tels Additional Information Updated View Revisions
19.06.2011 10:57 tels Note Added: 0003883
19.06.2011 10:58 tels Relationship added child of 0002779
23.06.2011 11:12 tels Note Added: 0003898
23.06.2011 11:12 tels Status assigned => resolved
23.06.2011 11:12 tels Fixed in Version => TDM 1.07
23.06.2011 11:12 tels Resolution open => fixed