View Issue Details

IDProjectCategoryView StatusLast Update
0002787The Dark ModFeature proposalpublic08.10.2017 18:31
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.06 
Target VersionTDM 1.07Fixed in VersionTDM 1.07 
Summary0002787: Complete Vine Arrow
Description90% of the vine arrow is in place. Need to complete the remaining 10%.
TagsNo tags attached.

Relationships

related to 0000626 closed Climbing on ladder takes up too much space, player needs a larger "hatch" to climb up through than he ought to. 

Activities

grayman

grayman

01.07.2011 03:45

administrator   ~0003905

What was already done:

1. Arrow icon.
2. Arrow model that attaches to the bow.
3. Arrow projectile.
4. Script to turn a vine arrow surface collision into a patch of vines that can be climbed.
5. Pick up a vine arrow.
6. Don’t allow vines to grow on flat surfaces.


What needed to be done:

 1. Add the vine arrow to the weapon set in the slot after the moss arrow. The player needs to assign the “0” key to the vine arrow, but on new installs it comes pre-assigned in DoomConfig.cfg.
 2. Randomize growth in a more natural-looking sequence. Growth should favor the forward direction of the arrow, which allows players to create growth up, down, or across surfaces.
 3. Allow vine arrows in the shop.
 4. Hit a vine patch with a water arrow and it should grow, like moss does. Though the design discussion said to limit this to 1 arrow, allow multiple arrows. Water should stimulate growth in the vines near where it hits. A vine piece can only be stimulated once. Limit the number of pieces in the same vine family that can be stimulated by a water stim to 2, to keep down overgrowth. (Each spawns 2 vine pieces, so watering adds at most 4 new pieces.)
 5. Restrict the materials a vine can grow on.
 6. Pick and implement a sound for a failed arrow hit.
 7. Pick a growing sound for each vine piece.
 8. (Springheel) Change model to allow more random growth patterns. The new model needs to be climbable.
 9. Failed arrow hits should not destroy the arrow. It should be retrievable.
 10. Keep failed arrows from sticking in patches.
 11. Prevent vines from growing in water.
 12. Add vine arrows to the misc prefabs.
 13. Add vine arrows to the startmap.

What wasn’t done:

 1. Don’t let the player stand on the top of vines. This will not be done now, since it’s important to find out how letting the player travel above the top of a climbing surface ties in with climbing off the top of a ladder.

rev. 4908:

ProjectileResult.h
ProjectileResult.cpp
ai.cpp
physics_player.cpp
script_thread.h
script_thread.cpp
entity.h
entity.cpp
misc.h
misc.cpp
projectile.cpp

rev 12044:

tdm_shopitems.def
tdm_player_thief.def
tdm_campaign.def
tdm_weapon_vinearrow.def
DoomConfig.cfg
mainmenu_settings_controls.gui
tdm_stone_brick.mtr
tdm_metal_grate.mtr
tdm_decals_vegetation.mtr
tdm_stone_cobblestones.mtr
tdm_roof.mtr
tdm_nature_dirt.mtr
StartTools,Ammo.pfb
ShopItems.pfb
StartObjectives,Shop,Tools,Ammo.pfb
tdm_events.script
tdm_weapon_vinearrow_result.script
tdm_main.script
startmap.pk4
bug2787.map
grayman

grayman

18.10.2011 21:16

administrator   ~0004081

Climbing is smoother.

Rev. 5001:

physics_player.cpp

Issue History

Date Modified Username Field Change
21.06.2011 14:37 grayman New Issue
21.06.2011 14:37 grayman Status new => assigned
21.06.2011 14:37 grayman Assigned To => grayman
01.07.2011 03:45 grayman Note Added: 0003905
01.07.2011 03:45 grayman Status assigned => resolved
01.07.2011 03:45 grayman Resolution open => fixed
01.07.2011 03:45 grayman Fixed in Version => TDM 1.07
18.10.2011 21:16 grayman Note Added: 0004081
08.10.2017 18:31 nbohr1more Relationship added related to 0000626