View Issue Details

IDProjectCategoryView StatusLast Update
0002925The Dark ModAIpublic10.10.2017 21:30
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0002925: AI should look at target when warning
DescriptionWhen AI greet each other, they turn their heads towards each other. When warning, however, they don't. This would be something to add when warning behaviour is improved for 1.08.
TagsNo tags attached.

Relationships

related to 0002245 acknowledged AI striking player transfers pain to player's teammate 

Activities

grayman

grayman

03.04.2013 16:34

administrator   ~0005282

Add random 1-2 second AI->AI “look” when issuing a warning. Can’t tie the duration of the look to the length of the warning, because it’s unknown at that moment exactly which bark will be emitted.

Ditto for AI->player greeting or warning.

rev. 5733:

State.cpp

Issue History

Date Modified Username Field Change
14.11.2011 01:42 Springheel New Issue
14.11.2011 01:42 Springheel Assigned To => grayman
14.11.2011 01:42 Springheel Status new => assigned
03.04.2013 16:34 grayman Note Added: 0005282
03.04.2013 16:34 grayman Status assigned => resolved
03.04.2013 16:34 grayman Resolution open => fixed
03.04.2013 16:34 grayman Fixed in Version => TDM 2.00
03.04.2013 16:34 grayman Target Version => TDM 2.00
10.10.2017 21:30 nbohr1more Relationship added related to 0002245