View Issue Details

IDProjectCategoryView StatusLast Update
0002997The Dark ModSaving/Loadingpublic10.03.2012 17:17
Reportergrayman Assigned Totaaaki  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0002997: SVN TDM (1.08) not saving games properly
DescriptionI just tried saving a game while testing my WIP.

The WIP lives in the Doom 3 folder, next to darkmod. ( Doom 3/<mygame> )

When you go to the Save/Load screen, existing savegames are shown. So TDM is reading Doom 3/<mygame>/savegames correctly.

But if save another game, it doesn't show on the Save/Load screen. TDM saved it in Doom 3/darkmod/fms/<mygame>/savegames.

If I restart TDM, it ignores Doom 3/darkmod/fms/<mygame>/savegames.

TagsNo tags attached.

Relationships

related to 0003034 resolvedtaaaki DoomConfig.cfg read/write locations 

Activities

taaaki

taaaki

30.01.2012 20:28

administrator   ~0004283

I've submitted a patch to fix the paths (rev. 5239 & 5240), so savegames should show up in the Load/Save Game menu. This probably requires more testing, so if anyone notices that TDM can't find other types files, it's probably this patch.

The problem where loading a savegame starts you at the beginning of the mission still exists.
grayman

grayman

31.01.2012 01:35

administrator   ~0004284

I can't build engines, so I'll test this the next time a Windows engine is built and released to SVN with the changes.

Thanks for working on this, and welcome to the crew!
AluminumHaste

AluminumHaste

01.02.2012 01:37

developer   ~0004285

I just compiled latest release with update 5240 savegames now work properly, but loading a quick save or a manual save always brings you back to the beginning of the mission.
taaaki

taaaki

01.02.2012 04:05

administrator   ~0004286

Yeah, I'm busy looking into why it resets the mission when you load. I'll probably on have time to dig into it properly sometime this weekend though.

serpentine mentioned that deleting saves is also broken, but that should be easier to fix than the mission reset issue.
taaaki

taaaki

08.02.2012 05:59

administrator   ~0004314

I have committed a simple patch that should fix the loading of savegames (serpentine has a knack for making wild guesses that end up being mostly correct).

If you have tdm_force_savegame_load 0 set, you will need to make sure that you test with saves made on the latest revision. The load game code checks whether or not the SVN revision has changed and if so, it will just load the map without any progress.

Setting tdm_force_savegame_load to 1, will bypass this check. Recent savegames should still load fine, but it is not advisable to keep it set to 1 as later changes to the game will likely result in invalid savegames.
taaaki

taaaki

11.02.2012 12:26

administrator   ~0004319

Keep in mind that you will start at the beginning of the level if you are loading a save made using a prior SVN revision that your current build (intended).

Revision 5239:
 Common.cpp
 FileSystem.h
 FileSystem.cpp

Revision 5240 & 5242:
 FileSystem.cpp

Revision 5257:
 SaveGame.cpp

Issue History

Date Modified Username Field Change
27.01.2012 13:34 grayman New Issue
30.01.2012 20:28 taaaki Note Added: 0004283
31.01.2012 01:35 grayman Note Added: 0004284
31.01.2012 06:57 greebo Assigned To => taaaki
31.01.2012 06:57 greebo Status new => assigned
01.02.2012 01:37 AluminumHaste Note Added: 0004285
01.02.2012 04:05 taaaki Note Added: 0004286
08.02.2012 05:59 taaaki Note Added: 0004314
11.02.2012 12:26 taaaki Note Added: 0004319
11.02.2012 12:26 taaaki Status assigned => resolved
11.02.2012 12:26 taaaki Fixed in Version => TDM 1.08
11.02.2012 12:26 taaaki Resolution open => fixed
10.03.2012 16:09 tels Relationship added related to 0003034
10.03.2012 17:17 tels Target Version => TDM 1.08