View Issue Details

IDProjectCategoryView StatusLast Update
0003002The Dark ModCodingpublic16.02.2020 21:31
ReporterSpringheel Assigned ToSerpentine  
PriorityurgentSeveritycrashReproducibilitysometimes
Status closedResolutionreopened 
Product VersionSVN 
Target VersionTDM 1.08Fixed in VersionTDM 2.08 
Summary0003002: Screenshots still crashing on Linux
DescriptionTrying to take a screenshot under linux (without D3 installed, not sure if this is important) still crashes with this message:

]screenshot
Bogus input colorspace
ModelGenerator memory: No LOD entries.
pure virtual method called
terminate called without an active exception
signal caught: Aborted
si_code -6
Trying to exit gracefully..
pure virtual method called
terminate called recursively
double fault Aborted, bailing out
shutdown terminal support

TagsNo tags attached.

Relationships

related to 0002982 resolvedgreebo jpeg's used in material stages result in artifacts 
related to 0003267 assignedSerpentine libjpg using incorrectly on linux/windows 

Activities

Serpentine

Serpentine

02.02.2012 21:12

developer   ~0004291

The path seems to be correct, writes work correctly with png's. I assume that its the same issue that causes the mission preview shots to cause a crash.

The thread about this is at : http://forums.thedarkmod.com/topic/13457-screenshot-f12-locks-up-doom3/

As I haven't really played with the IL stuff, I'll assign this to greebo for now.
@greebo - you can assign it back if you're busy atm.
taaaki

taaaki

15.04.2012 14:49

administrator   ~0004462

I think I've fixed this for JPEGs.

In il_jpeg: Since RGB_PIXELSIZE was changed to 4, the conversion to RGB is short one colour component. This results in an error being thrown by DevIL, causing screenshots to crash.

Revision 5388:
  lib/devil/il_jpeg.c
  win32/devil/lib/DevIL.lib
  win32/devil/lib/devil.pdb
AluminumHaste

AluminumHaste

16.04.2012 00:25

developer   ~0004466

Issue fixed, thank you Taaaki, this also fixes the crash with viewing jgp's in the download missions menu.
Springheel

Springheel

19.04.2012 13:01

administrator   ~0004482

At least two people have reported that this is still crashing.
taaaki

taaaki

19.04.2012 18:26

administrator   ~0004485

The fix for screenshots is from revision 5388 onwards, so make sure that your binaries are the same or later revision than that (console should tell you).
tels

tels

01.05.2012 15:27

developer   ~0004507

Last edited: 01.05.2012 15:28

View 2 revisions

Trying to take a screenshot under linux (without D3 installed, not sure if this is important) still crashes with this message:

]screenshot
Bogus input colorspace
ModelGenerator memory: No LOD entries.
pure virtual method called
terminate called without an active exception
signal caught: Aborted
si_code -6
Trying to exit gracefully..
pure virtual method called
terminate called recursively
double fault Aborted, bailing out
shutdown terminal support


r_screenshot_format is jpg for me.

tels

tels

01.05.2012 15:31

developer   ~0004508

A cursory look into the code shows that libjpg expects RGB to be 3 pixels, but the fix for 0002982 talks about setting it to 4 (RGBA?). So maybe there is some mismatch here.
Serpentine

Serpentine

05.05.2012 02:58

developer   ~0004532

taaaki - You can reassign this to me, I have a better way of dealing with this, and patches.

I've upgraded the existing TGA writer, and I plan to move over the screenshot functionality to use that anyway. The TGA writer by default will use a 4 channel TGA, I will add in a second version to write 3 channel TGAs for use with screenshots, where the alpha channel will always be redundant (and drop file sizes by 25%). This should also fix the current Devil loading which seems a bit wonky (tho it could be the screenshot function writing a bad header, but that'll be replaced by this anyway.)
tels

tels

05.05.2012 09:46

developer   ~0004534

I am not sure what a TGA writer has to do with the JPG screenshots crashing.
Springheel

Springheel

08.09.2012 01:39

administrator   ~0004805

Can anyone confirm that this happens when D3 is installed? If it only happens when running standalone then we should leave it for 1.09.
tels

tels

09.09.2012 07:42

developer   ~0004817

It also appears with D3 installed. It really has to do with the linux libDevil being different (we use the systemlib on linux, not the one compiled in on windows).

On windows, the lib expects 4 bytes per pixel (RGBA), so we send it that. The lib on linux expects 3 pixels (RGB), so it barfs when it gets 4 pixel. (or vice, versa, I am not sure on the specific counts).
greebo

greebo

17.09.2012 07:27

administrator   ~0004834

Since the engine requires any image to be 4 bpp the only easy solution is to use our own jpeg lib, just like we did before. The sconscript should be easy to do, I might even find some time to look into it.
greebo

greebo

17.09.2012 16:14

administrator   ~0004836

Added the sconscript.libjpeg and adjusted the sconscripts to use the local libjpeg instead of the system one.
tels

tels

05.12.2012 07:49

developer   ~0004957

This still does not work with v1.08 on Linux for whatever reasons, screenshots in JPG format still crash TDM.
cabalistic

cabalistic

16.02.2020 21:31

developer   ~0012213

Closing as this is an ancient report. Screenshots work for me on current SVN.

Issue History

Date Modified Username Field Change
02.02.2012 15:32 Springheel New Issue
02.02.2012 21:12 Serpentine Note Added: 0004291
02.02.2012 21:13 Serpentine Assigned To => greebo
02.02.2012 21:13 Serpentine Status new => assigned
24.03.2012 16:55 greebo Assigned To greebo =>
24.03.2012 16:55 greebo Status assigned => acknowledged
08.04.2012 03:21 Serpentine Assigned To => Serpentine
08.04.2012 03:21 Serpentine Status acknowledged => assigned
15.04.2012 02:54 Serpentine Priority normal => urgent
15.04.2012 02:54 Serpentine Severity normal => crash
15.04.2012 02:54 Serpentine Reproducibility have not tried => sometimes
15.04.2012 02:54 Serpentine Summary Screenshot causing crash? => Screenshots using DevIL (jpeg/png) can crash
15.04.2012 02:54 Serpentine Description Updated View Revisions
15.04.2012 14:42 taaaki Assigned To Serpentine => taaaki
15.04.2012 14:42 taaaki Relationship added related to 0002982
15.04.2012 14:49 taaaki Note Added: 0004462
16.04.2012 00:25 AluminumHaste Note Added: 0004466
16.04.2012 14:55 taaaki Status assigned => resolved
16.04.2012 14:55 taaaki Fixed in Version => TDM 1.08
16.04.2012 14:55 taaaki Resolution open => fixed
19.04.2012 13:01 Springheel Note Added: 0004482
19.04.2012 13:01 Springheel Status resolved => assigned
19.04.2012 13:02 Springheel Target Version => TDM 1.08
19.04.2012 18:26 taaaki Note Added: 0004485
01.05.2012 15:27 tels Note Added: 0004507
01.05.2012 15:28 tels Note Edited: 0004507 View Revisions
01.05.2012 15:31 tels Note Added: 0004508
01.05.2012 15:31 tels Product Version TDM 1.08 => SVN
01.05.2012 15:31 tels Fixed in Version TDM 1.08 =>
05.05.2012 02:58 Serpentine Note Added: 0004532
05.05.2012 07:31 taaaki Assigned To taaaki => Serpentine
05.05.2012 09:46 tels Note Added: 0004534
24.05.2012 13:22 Springheel Summary Screenshots using DevIL (jpeg/png) can crash => Screenshots still crashing on Linux
24.05.2012 13:22 Springheel Description Updated View Revisions
08.09.2012 01:38 Springheel Assigned To Serpentine =>
08.09.2012 01:39 Springheel Note Added: 0004805
09.09.2012 07:42 tels Note Added: 0004817
13.09.2012 22:40 Springheel Assigned To => Springheel
13.09.2012 22:40 Springheel Status assigned => new
14.09.2012 21:33 Springheel Assigned To Springheel =>
17.09.2012 07:27 greebo Note Added: 0004834
17.09.2012 16:14 greebo Assigned To => greebo
17.09.2012 16:14 greebo Status new => assigned
17.09.2012 16:14 greebo Note Added: 0004836
17.09.2012 16:14 greebo Status assigned => resolved
17.09.2012 16:14 greebo Fixed in Version => TDM 1.08
05.12.2012 07:49 tels Note Added: 0004957
05.12.2012 07:49 tels Status resolved => assigned
05.12.2012 07:49 tels Resolution fixed => reopened
05.12.2012 07:49 tels Description Updated View Revisions
05.12.2012 07:51 tels Relationship added related to 0003267
05.12.2012 07:51 tels Assigned To greebo => Serpentine
16.02.2020 21:31 cabalistic Status assigned => closed
16.02.2020 21:31 cabalistic Fixed in Version TDM 1.08 => TDM 2.08
16.02.2020 21:31 cabalistic Note Added: 0012213