View Issue Details

IDProjectCategoryView StatusLast Update
0003010The Dark ModCodingpublic08.02.2012 03:52
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003010: Add sounds to player mantle
DescriptionMantling is handled in the SDK. There are four phases: hang, pull up, shift hands, push down. I see no code to issue sounds, though with four distinct phases, I assume the spots where a sound could be issued would be obvious and not much work to add.

The current player soundshader is tdm_player_mantle. The current sounds would probably be most appropriate to play at the "pull up" stage. Though adding the subtle sound of hands grabbing on the "hang" phase might also be a nice touch.
TagsNo tags attached.

Activities

grayman

grayman

05.02.2012 03:46

administrator   ~0004297

Is there a "hands grabbing" sound & shader?
grayman

grayman

05.02.2012 05:44

administrator   ~0004298

Mantling doesn't always go through the 4 phases. Most times it starts with the final phase, pushing down.

Atm, here are the different cases, and when you'll hear the sound:

1. hang->sound->pull->shift->push
2. sound->pull->shift->push
3. shift->sound->push
4. sound->push

Case 1 is sort of odd, because some time passes between the start of a pull and the end of a push, so you make a sound when pulling yourself up, but you don't make a sound when pushing yourself onto the ledge at the end.

Compare this to case 4, when you'll hear the sound as you push yourself onto the ledge.

Allowing the sound both at pull and push doesn't sound right.

What might sound better is if there's a unique pull sound and a unique push sound, and you don't mind hearing one after the other. This would work best as a 'pulling hard to get myself up there' sound, followed by a 'good, I made it' sound.

Then we'd have this:

1. hang->pull sound->pull->shift->push_sound->push
2. pull sound->pull->shift->push_sound->push
3. shift->push_sound->push
4. push_sound->push
grayman

grayman

05.02.2012 19:17

administrator   ~0004300

Play pull-up and push-down sounds at appropriate points in the mantling sequence.

rev. 5245:

Physics_Player.cpp

Rev. 12591:

tdm_player_thief.def
grayman

grayman

08.02.2012 03:52

administrator   ~0004313

Change SND_CHANNEL_ANY to SND_CHANNEL_VOICE.

rev. 5256:

Physics_Player.cpp

Issue History

Date Modified Username Field Change
05.02.2012 01:19 Springheel New Issue
05.02.2012 01:19 Springheel Status new => assigned
05.02.2012 01:19 Springheel Assigned To => grayman
05.02.2012 03:46 grayman Note Added: 0004297
05.02.2012 05:44 grayman Note Added: 0004298
05.02.2012 19:17 grayman Note Added: 0004300
05.02.2012 19:17 grayman Status assigned => resolved
05.02.2012 19:17 grayman Resolution open => fixed
05.02.2012 19:17 grayman Product Version TDM 1.08 => TDM 1.07
05.02.2012 19:17 grayman Fixed in Version => TDM 1.08
05.02.2012 19:17 grayman Target Version => TDM 1.08
08.02.2012 03:52 grayman Note Added: 0004313