View Issue Details

IDProjectCategoryView StatusLast Update
0003026The Dark ModCodingpublic25.02.2012 23:08
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003026: Add "tired" sounds to Bow Draw
DescriptionThere are exertion sounds to play when the player's bow draw starts to wobble, but they're currently not called by the code. Not sure what the sound shader name is--I'm at work--but wanted to get this tracked...I imagine it's an easy fix. The sound just needs to be called at the same instant the bow view starts to wave back and forth. If the sound ends too early or too late, I can modify the sounds to fit as needed after the fact.

TagsNo tags attached.

Activities

grayman

grayman

24.02.2012 21:14

administrator   ~0004349

Add “snd_player_tired” to the player def and play it when the tired animation begins.

rev. 12645:

tdm_player_thief.def
tdm_weapon_arrow.script
grayman

grayman

24.02.2012 21:15

administrator   ~0004350

SH: You might have to alter the sounds, since they end well before the animation ends. See what you think.
Springheel

Springheel

25.02.2012 18:46

administrator   ~0004354

Last edited: 25.02.2012 19:22

View 2 revisions

I've updated the sounds with ones that match the duration of the wobble, but one slight hiccup is that once started, the full sound plays even if the player fires the arrow in the middle of it.

grayman

grayman

25.02.2012 19:12

administrator   ~0004355

4 seconds if you let it play out. When it hits the 4s mark, the bow begins to come down.

If you change the sound so it lasts 4s, I can stop the sound if the animation aborts for any reason.
Springheel

Springheel

25.02.2012 19:23

administrator   ~0004356

ninja'd!
grayman

grayman

25.02.2012 20:07

administrator   ~0004357

If the draw loop aborts after the tired sound starts, stop the sound.

rev 12651

Issue History

Date Modified Username Field Change
17.02.2012 16:49 Springheel New Issue
17.02.2012 16:49 Springheel Status new => assigned
17.02.2012 16:49 Springheel Assigned To => grayman
24.02.2012 21:14 grayman Note Added: 0004349
24.02.2012 21:14 grayman Status assigned => resolved
24.02.2012 21:14 grayman Resolution open => fixed
24.02.2012 21:14 grayman Fixed in Version => TDM 1.08
24.02.2012 21:14 grayman Target Version => TDM 1.08
24.02.2012 21:15 grayman Note Added: 0004350
25.02.2012 13:51 Springheel Assigned To grayman => Springheel
25.02.2012 13:51 Springheel Status resolved => assigned
25.02.2012 18:46 Springheel Note Added: 0004354
25.02.2012 19:12 grayman Note Added: 0004355
25.02.2012 19:22 Springheel Note Edited: 0004354 View Revisions
25.02.2012 19:23 Springheel Note Added: 0004356
25.02.2012 20:07 grayman Note Added: 0004357
25.02.2012 23:08 Springheel Status assigned => resolved