View Issue Details

IDProjectCategoryView StatusLast Update
0003057The Dark ModCodingpublic26.03.2013 04:08
ReporterAluminumHaste Assigned Totaaaki  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformX64 
Product VersionSVN 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003057: Deleting FM folder of installed mission causes DarkMod to break/crash
DescriptionI deleted a mission in the darkmod\fms folder that was currently installed in DarkMod. I then started up DarkMod and went to install a new mission. I noticed that the Uninstall Mission option was available. I clicked Uninstall Mission and DarkMod restarted.
I get the ID logo and the darkmod menu music playing but the screen is black, and console is showing obivous warnings that it couldn't find fonts and guis etc.
I can't get it working now. currentfm.txt is blank. I typed in "thieves" in the currentfm.txt and DarkMod loaded up the Thieves mission and main menu is working again.
I then properly uninstalled the mission and DarkMod is still working.
Steps To ReproduceInstall an FM.
Exit DarkMod.
Go to Darkmod\fms\ and delete the installed FM folder
Start TheDarkMod.exe and observe broken game.
Additional InformationI was only able to fix this because I had other missions in my FM folder that I could manually set in the currentfm.txt file. If I had none I would be out of luck.
TagsNo tags attached.

Relationships

related to 0003115 resolvedtaaaki .lin (pointfile) cannot be written if maps/ does not exist 
related to 0003125 resolvedtaaaki Revising Framework/FileSystem for clarity 
related to 0003117 resolvedtaaaki Need release plan for old gamex86.dlls 
related to 0003351 resolvedtaaaki Game crashes on load if no FM in fms folder. 

Activities

tels

tels

01.05.2012 15:25

reporter   ~0004506

Removing the contents of "currentfm.txt" seems to help, too, but then you lose all your config settings and have to re-install any FM to be able to save them again.
grayman

grayman

05.05.2012 15:40

administrator   ~0004540

Using the latest SVN, I followed the steps that lead to the crash, but TDM didn't crash. The main menu came up fine.

Can you reproduce this problem today?

If so, I want a list of all missions in fms and the name of the mission whose folder you delete to cause the crash.
AluminumHaste

AluminumHaste

09.05.2012 19:46

developer   ~0004559

It didn't crash for me either I don't know why this is listed as Crash. I just got the weird black screen with the darkmod menu music playing in the background.
Springheel

Springheel

02.06.2012 12:33

administrator   ~0004651

So is this still a problem or not?
AluminumHaste

AluminumHaste

02.06.2012 15:34

developer   ~0004652

When Grayman asked me to try it again on the 5th I did try it and it screwed up. But I just compiled newest source and now it no longer seems to be an issue. The main menu comes up just fine. Going to new mission however shows that nothing is installed, and when I press start mission the dark mod video shows and a blank parchement page is there with objectives at the bottom right. If I press Objectives I get a console window with errors.

This should be changed so that if there is anything missing from the installed FMs folder that are needed to make the map run, Darkmod should default to no installed mission state.
taaaki

taaaki

17.06.2012 16:34

administrator   ~0004667

Initial fix for this in Revision 5480. At the moment I just check if the directory is there, but in the future, we can look for other required files like either a pk4 or .map.

On that note, exactly which files are required to count a mission as available?
AluminumHaste

AluminumHaste

17.06.2012 17:10

developer   ~0004668

Well if there's a pk4 check for a map file inside. If no pk4 exists look for a map file in the /maps folder of installed fm?
taaaki

taaaki

20.09.2012 20:13

administrator   ~0004842

Additional fan mission checks add in darmod_src SVN rev. 5573. The startup code now checks for the existence of a .pk4 file in <fm folder>/ or .map file in <fm folder>/maps/

I did not go as far as confirming the name of the pk4 (the name of the pk4 file doesn't seem to affect the ability to load the mission) or map file and I did not verify the existence of a map file within the pk4, but this should be sufficient to avoid issues (hopefully). Can I mark issue 0003057 (after testing of the changes) or should I check the file names and existence of map file in the pk4?
Springheel

Springheel

21.09.2012 00:26

administrator   ~0004843

I don't think it's our job to check that there's a map file in the pk4.
taaaki

taaaki

21.09.2012 19:06

administrator   ~0004844

Sufficient checks added to guard against missing mission folders and/or map files.

Issue History

Date Modified Username Field Change
11.03.2012 02:56 AluminumHaste New Issue
11.03.2012 02:57 AluminumHaste Priority immediate => high
11.03.2012 02:57 AluminumHaste Summary Deleting FM folding of installed mission causes DarkMod to break => Deleting FM folder of installed mission causes DarkMod to break
01.05.2012 15:24 tels Severity major => crash
01.05.2012 15:24 tels Category GUI => Coding
01.05.2012 15:24 tels OS Windows =>
01.05.2012 15:24 tels OS Version 7 Ultimate =>
01.05.2012 15:25 tels Note Added: 0004506
01.05.2012 15:25 tels Summary Deleting FM folder of installed mission causes DarkMod to break => Deleting FM folder of installed mission causes DarkMod to break/crash
05.05.2012 15:40 grayman Note Added: 0004540
06.05.2012 12:42 tels Relationship added related to 0003115
09.05.2012 19:20 taaaki Relationship added related to 0003125
09.05.2012 19:46 AluminumHaste Note Added: 0004559
09.05.2012 19:47 AluminumHaste Severity crash => major
11.05.2012 14:45 tels Relationship added related to 0003117
02.06.2012 12:33 Springheel Note Added: 0004651
02.06.2012 15:34 AluminumHaste Note Added: 0004652
16.06.2012 19:59 taaaki Assigned To => taaaki
16.06.2012 19:59 taaaki Status new => assigned
17.06.2012 16:34 taaaki Note Added: 0004667
17.06.2012 17:10 AluminumHaste Note Added: 0004668
20.09.2012 20:13 taaaki Note Added: 0004842
21.09.2012 00:26 Springheel Note Added: 0004843
21.09.2012 19:06 taaaki Note Added: 0004844
21.09.2012 19:06 taaaki Status assigned => resolved
21.09.2012 19:06 taaaki Fixed in Version => TDM 1.08
21.09.2012 19:06 taaaki Resolution open => fixed
26.03.2013 04:08 taaaki Relationship added related to 0003351