View Issue Details

IDProjectCategoryView StatusLast Update
0003067The Dark ModCodingpublic05.05.2012 18:07
ReporterSpringheel Assigned Totels  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003067: Shadow comes on before light disappears
DescriptionWhen torches and candles go out, something weird happens. The torches suddenly cast a _huge_ shadow for a second. It's as if the flame you just extinguished is casting a shadow even though the particle is gone. It then blinks out

The candles also do something weird when extinguished. For a second there is a sliver of light on the wall which then disappears. Might be the same cause as the torch shadow.

http://forums.thedarkmod.com/topic/13564-lamp-glass/page__pid__281809__st__25#entry281809
Additional InformationAs for the shadow "pop", I think that can be mitigated by the code delaying turning on the shadow until the light has gone out
TagsNo tags attached.

Activities

tels

tels

22.03.2012 18:24

reporter   ~0004424

Just so this doesn't get forgotten:

The "delay the shadow until the light is off" is actually still a work-around in the form of "have a shadow only when unlit".

A much better solution would be if we could tag certain entities with "no self shadowing from attached lights" and then a light will simply not cast a shadow from any entities on the same bind team.

Right now, entities either cast a shadow from a light source (if the light source is shadow casting and the entity, too), or not, but they can't selectively have a shadow from light X, and not from light Y.

Implementing this in the engine might be complicated, or dead simple, but I don't have enough understandings of the innards to deduce if that would be possible. But having that ability would be a much cleaner solution, because then we could remove the entire shadow switching thing altogether.
tels

tels

20.04.2012 09:20

reporter   ~0004488

The light holder script was fixed with revision #12772 to toggle the shadow on with a delay of 100ms, but I cannot test this (TDM no longer runs on linux for me). Can somebody please report back?
Springheel

Springheel

21.04.2012 00:37

administrator   ~0004490

Last edited: 21.04.2012 00:38

View 2 revisions

Tried some candles in light_entity.map. The candles without holders still cast shadows before the light went off. So did the candle in a bottle. But the candles in the typical holders seemed to be fixed.

tels

tels

22.04.2012 08:45

reporter   ~0004491

Could you make a very small testmap with just the three entities where one can observe the difference?

Technically, all use the same light holder script, so all should show the same behaviour.
Springheel

Springheel

22.04.2012 12:51

administrator   ~0004492

On more testing, it seems like the shadows on the candle holders are fixed. But the candles themselves still cast shadows if they're close enough to a wall to do so.
Springheel

Springheel

27.04.2012 01:24

administrator   ~0004497

It also appears that torches are still exhibiting the problem behaviour.
tels

tels

01.05.2012 14:04

reporter   ~0004505

I was wrong, the delayed shadow was only used in the script for the ligh entities itself, but not in the script for the light holders. Oops :)

This is now fixed, and should now work. If not, please re-open this bug report.
Springheel

Springheel

02.05.2012 01:16

administrator   ~0004513

Last edited: 02.05.2012 01:22

View 3 revisions

I tested torches and campfires, and the issue is still there. It might be for a slightly shorter period of time than before (hard to say).

tels

tels

02.05.2012 18:52

reporter   ~0004517

grayman says:

"I tried 200 and could still see the shadow.

Then I tried 400 and couldn't see it.

I tested a few different types of light holders and saw no issues dousing or lighting them.

Checked in, rev 12798."
Springheel

Springheel

05.05.2012 18:07

administrator   ~0004545

One issue is that now electric light shadows don't come on for half a second. Since electric lights turn off instantly, the delay in the shadow coming on is noticaeble. Given the choice, though, I'd rather have this problem than the other.

Issue History

Date Modified Username Field Change
22.03.2012 14:39 Springheel New Issue
22.03.2012 14:39 Springheel Status new => assigned
22.03.2012 14:39 Springheel Assigned To => tels
22.03.2012 18:18 tels Severity normal => minor
22.03.2012 18:18 tels Product Version TDM 1.08 => TDM 1.07
22.03.2012 18:18 tels Target Version => TDM 1.08
22.03.2012 18:24 tels Note Added: 0004424
16.04.2012 17:56 tels Assigned To tels =>
16.04.2012 17:56 tels Status assigned => new
20.04.2012 09:20 tels Note Added: 0004488
20.04.2012 09:20 tels Assigned To => tels
20.04.2012 09:20 tels Status new => feedback
21.04.2012 00:37 Springheel Note Added: 0004490
21.04.2012 00:37 Springheel Status feedback => assigned
21.04.2012 00:38 Springheel Note Edited: 0004490 View Revisions
22.04.2012 08:45 tels Note Added: 0004491
22.04.2012 12:51 Springheel Note Added: 0004492
27.04.2012 01:24 Springheel Note Added: 0004497
01.05.2012 14:04 tels Note Added: 0004505
01.05.2012 14:04 tels Status assigned => resolved
01.05.2012 14:04 tels Fixed in Version => TDM 1.08
01.05.2012 14:04 tels Resolution open => fixed
02.05.2012 01:16 Springheel Note Added: 0004513
02.05.2012 01:16 Springheel Status resolved => assigned
02.05.2012 01:17 Springheel Note Edited: 0004513 View Revisions
02.05.2012 01:22 Springheel Note Edited: 0004513 View Revisions
02.05.2012 18:52 tels Note Added: 0004517
02.05.2012 18:52 tels Status assigned => resolved
05.05.2012 18:07 Springheel Note Added: 0004545