View Issue Details

IDProjectCategoryView StatusLast Update
0003077The Dark ModAIpublic07.04.2012 22:09
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003077: Dousing a carried torch during relight causes problems
DescriptionIf you douse an AI's torch while he's approaching a light to relight it, the torch never gets dropped.
TagsNo tags attached.

Activities

grayman

grayman

07.04.2012 22:09

administrator   ~0004449

Aborting the relight when a torch is doused causes the drop torch animation to be cleared. Since it can’t complete, the AI is left in a state where he’ll never drop his doused torch.

Also noticed that the light entity on a desk lamp had changed its origin, probably in all the changes made to lights for 1.08. Now it’s considered a “high” light for relight purposes, and a relighting AI will use the “reach up high” animation, which looks wrong. Bumped the threshold for high lights from 65 to 66, which solves the problem.

rev. 5370:

State.cpp
SwitchOnLightState.cpp

Issue History

Date Modified Username Field Change
07.04.2012 18:25 grayman New Issue
07.04.2012 18:25 grayman Status new => assigned
07.04.2012 18:25 grayman Assigned To => grayman
07.04.2012 22:09 grayman Note Added: 0004449
07.04.2012 22:09 grayman Status assigned => resolved
07.04.2012 22:09 grayman Resolution open => fixed
07.04.2012 22:09 grayman Fixed in Version => TDM 1.08