View Issue Details

IDProjectCategoryView StatusLast Update
0003078The Dark ModAIpublic20.02.2013 00:50
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003078: AI are inconsistent when finding neutral bodies
DescriptionGiven a Builder guard (team 1) and a pagan (team 7, aka neutral).

If the two pass one another, the guard will no longer respond to the pagan's visibility stim afterward. Should the pagan die, the guard won't notice the body.

If the two don't meet before the pagan dies, the guard notices the body.

If the pagan leaves a blood marker, the guard will always notice it.

1 - guards shouldn't notice neutrals, dead or alive.

2 - guards shouldn't notice blood if it's near a neutral body, and should notice blood if it's by itself, because they can't tell whose it is.



TagsNo tags attached.

Activities

grayman

grayman

11.04.2012 00:29

administrator   ~0004458

Neutral dead bodies will no longer be noticed by the teams they’re neutral to.

Blood belonging to neutral bodies, and arrows sticking out of neutral bodies will now be ignored.

rev. 5379:

State.cpp
Entity.cpp
Springheel

Springheel

19.02.2013 17:22

administrator   ~0005083

"guards shouldn't notice neutrals, dead or alive."

Does this include greetings? We have specific greetings meant for beggars and pagans for some vocal sets.
grayman

grayman

19.02.2013 17:47

administrator   ~0005084

Yes, it includes greetings, but that's not my doing. The code was that way when I started looking at it more than 2 years ago.

The greeting code is roughly this:

if (enemy) then no greetings, since you'll be in combat in a moment.

otherwise, if (friend) then exchange greetings

otherwise, if (neutral) no greetings, and ignore them forever
Springheel

Springheel

19.02.2013 19:43

administrator   ~0005088

Huh. I didn't know that. We've got snide remarks for builders to greet pagans with, or nobles to greet beggars with, that aren't being used then.
grayman

grayman

19.02.2013 21:45

administrator   ~0005089

Last edited: 19.02.2013 21:46

View 2 revisions

There's already code to use the "snd_greeting_pagan" bark, but since pagans are neutral to everyone, it never gets run.

I can add the code to make that happen.

Springheel

Springheel

20.02.2013 00:50

administrator   ~0005090

I've made a new entry: 0003323

Issue History

Date Modified Username Field Change
08.04.2012 16:18 grayman New Issue
10.04.2012 00:46 grayman Assigned To => grayman
10.04.2012 00:46 grayman Status new => assigned
11.04.2012 00:29 grayman Note Added: 0004458
11.04.2012 00:29 grayman Status assigned => resolved
11.04.2012 00:29 grayman Resolution open => fixed
11.04.2012 00:29 grayman Fixed in Version => TDM 1.08
11.04.2012 00:29 grayman Target Version => TDM 1.08
19.02.2013 17:22 Springheel Note Added: 0005083
19.02.2013 17:47 grayman Note Added: 0005084
19.02.2013 19:43 Springheel Note Added: 0005088
19.02.2013 21:45 grayman Note Added: 0005089
19.02.2013 21:46 grayman Note Edited: 0005089 View Revisions
20.02.2013 00:50 Springheel Note Added: 0005090