View Issue Details

IDProjectCategoryView StatusLast Update
0003088The Dark ModDesign/Codingpublic05.10.2017 12:48
ReporterSerpentine Assigned ToSerpentine  
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product VersionSVN 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0003088: Port EAX/Old OpenAL to EFX/OpenAL Soft
DescriptionUsing the dhewm3 code, replace OpenAL with OpenAL Soft, update the stub, rework the hardcoded effects and generally port everything over.

This is complete, however needs to be committed and tested.
TagsNo tags attached.

Relationships

duplicate of 0003955 resolvedgreebo Port EAX code to use openAL/EFX based on dhewm3 
related to 0003079 resolvedSerpentine Crash in listSounds 
related to 0003222 resolved OpenAL not supported on Linux 
related to 0003221 confirmed TDM only supports 2 or 5.1 channel audio 
related to 0004629 closedSpringheel Surround Sound broken 

Activities

nbohr1more

nbohr1more

03.07.2012 13:01

developer   ~0004684

Does this accomplish the positional audio referred to here?

http://forums.thedarkmod.com/topic/12825-surround-sound-with-standard-headphones/
tels

tels

12.05.2013 11:37

developer   ~0005416

Any news on this?
nbohr1more

nbohr1more

13.03.2014 22:55

developer   ~0006440

Daniel Gibson has a "mod support project":

https://github.com/DanielGibson/dhewm3-base-mods

...where he has extended an open invitation to assist mod authors port projects to Dhewm3.

I've posted a request for assistance there.
nbohr1more

nbohr1more

07.12.2014 20:56

developer   ~0007221

Close this as a duplicate of 3955 ?

Issue History

Date Modified Username Field Change
18.04.2012 17:25 Serpentine New Issue
18.04.2012 17:25 Serpentine Status new => assigned
18.04.2012 17:25 Serpentine Assigned To => Serpentine
18.04.2012 17:31 Serpentine Relationship added related to 0003079
03.07.2012 13:01 nbohr1more Note Added: 0004684
07.09.2012 09:45 tels Relationship added related to 0003222
12.05.2013 11:36 tels Relationship added related to 0003221
12.05.2013 11:37 tels Note Added: 0005416
13.03.2014 22:55 nbohr1more Note Added: 0006440
07.12.2014 20:56 nbohr1more Note Added: 0007221
24.05.2017 16:51 nbohr1more Relationship added duplicate of 0003955
24.05.2017 16:53 nbohr1more Status assigned => closed
24.05.2017 16:53 nbohr1more Resolution open => duplicate
24.05.2017 16:53 nbohr1more Product Version => SVN
24.05.2017 16:53 nbohr1more Fixed in Version => TDM 2.06
24.05.2017 16:53 nbohr1more Target Version => TDM 2.06
05.10.2017 12:48 nbohr1more Relationship added related to 0004629