View Issue Details

IDProjectCategoryView StatusLast Update
0000031The Dark ModCodingpublic02.06.2008 13:39
ReporterSneaksieDave Assigned Tocrispy  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Fixed in VersionSVN 
Summary0000031: Can mantle up slopes
Descriptionsource:
http://modetwo.net/darkmod/index.php?s=&showtopic=5079&view=findpost&p=93942

It's possible to mantle up slopes that cannot be traversed with running or walking, by simply holding down the mantle key continuously.
TagsNo tags attached.

Activities

SneaksieDave

SneaksieDave

06.11.2007 03:19

developer   ~0000830

Last edited: 06.11.2007 03:19

This is still a problem. For repro, go to city_area.map, to the L-shaped largest building near the middle of the city. Noclip up to the roof, and drop yourself with enough room to act before falling to the street. Before you fall, start spamming the mantle key (_impulse24). You can go right up this very steep incline by doing this.

Jump mantle seems to be handled, because it is limited to one action per certain amount of time (during which you slide back down).

crispy

crispy

26.12.2007 04:57

reporter   ~0000938

Attempted fix now in code SVN, though updated PK4 is not yet uploaded to main repository. See http://modetwo.net/darkmod/index.php?showtopic=4463

Please test extensively before closing. We should also decide on a final value for the cvar pm_mantle_minflatness.
SneaksieDave

SneaksieDave

29.04.2008 15:50

developer   ~0001175

This appears to still be an issue. Here's a movie showing use of a spammed mantle key to get up a very steep slope in test/mantle:

http://208.49.149.118/thedarkmod/temp/mantleup.wmv
crispy

crispy

02.06.2008 02:07

reporter   ~0001227

I have set pm_mantle_minflatness to 0.707 (in the player's def file, and I also changed the default in code). This makes it impossible to mantle onto slopes steeper than 45 degrees (previous setting, 0.5, allowed you to mantle onto slopes less steep than 60 degrees). I believe this resolves the issue, since I believe 45 degrees is the steepest walkable slope for the player.

With this setting, I can't mantle onto any of the sloped ledges at the back of test/mantle.map except for the ones I can walk on; conversely, if I can walk on a slope then I can mantle it.
SneaksieDave

SneaksieDave

02.06.2008 13:39

developer   ~0001232

Looks good.

Issue History

Date Modified Username Field Change
23.01.2007 23:51 SneaksieDave New Issue
05.11.2007 03:57 Dram Status new => resolved
06.11.2007 03:19 SneaksieDave Status resolved => feedback
06.11.2007 03:19 SneaksieDave Resolution open => reopened
06.11.2007 03:19 SneaksieDave Note Added: 0000830
06.11.2007 03:19 SneaksieDave Note Edited: 0000830
26.12.2007 04:57 crispy Status feedback => resolved
26.12.2007 04:57 crispy Fixed in Version => SVN
26.12.2007 04:57 crispy Resolution reopened => fixed
26.12.2007 04:57 crispy Assigned To => crispy
26.12.2007 04:57 crispy Note Added: 0000938
29.04.2008 15:50 SneaksieDave Status resolved => feedback
29.04.2008 15:50 SneaksieDave Resolution fixed => reopened
29.04.2008 15:50 SneaksieDave Note Added: 0001175
02.06.2008 02:07 crispy Note Added: 0001227
02.06.2008 02:07 crispy Status feedback => resolved
02.06.2008 02:07 crispy Resolution reopened => fixed
02.06.2008 13:39 SneaksieDave Status resolved => closed
02.06.2008 13:39 SneaksieDave Note Added: 0001232