View Issue Details

IDProjectCategoryView StatusLast Update
0003123The Dark ModAIpublic10.05.2012 18:33
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003123: Need new torch animations and code corrections
DescriptionA torch-bearing AI with a weapon is missing at least two animations: searching (walking while searching) and standing idle after sheathing his weapon. In both cases, the torch is held at his side instead of forward and up.
TagsNo tags attached.

Activities

grayman

grayman

10.05.2012 04:25

administrator   ~0004561

Fixed several problems:

- A torch-bearing archer now drops his torch or lantern when alerted. The torch goes out, but I didn't fix the lantern not going out, even though it should.

- The script ignoring the presence of a torch when switching from 'walk' to 'walk_alerted' and vice-versa.

- A non-archer lantern-bearing AI now keeps his lantern when searching. He's only supposed to drop it in combat, but the def file was dropping it during searches.

rev 5443:

AI.cpp
AI_Events.cpp

rev 12851:

tdm_moveable_weapons.def
tdm_prop_items.def
tdm_ai_base.script
grayman

grayman

10.05.2012 18:33

administrator   ~0004565

I'm marking this resolved for 1.08.

I didn't do the comprehensive work I intended, but I did fix a few things and from here on we should fix individual problems as they are reported.

Issue History

Date Modified Username Field Change
09.05.2012 13:33 grayman New Issue
09.05.2012 13:33 grayman Status new => assigned
09.05.2012 13:33 grayman Assigned To => grayman
10.05.2012 04:25 grayman Note Added: 0004561
10.05.2012 04:25 grayman Assigned To grayman =>
10.05.2012 04:25 grayman Status assigned => confirmed
10.05.2012 04:25 grayman Target Version TDM 1.08 =>
10.05.2012 18:33 grayman Note Added: 0004565
10.05.2012 18:33 grayman Assigned To => grayman
10.05.2012 18:33 grayman Status confirmed => resolved
10.05.2012 18:33 grayman Resolution open => fixed
10.05.2012 18:33 grayman Fixed in Version => TDM 1.08
10.05.2012 18:33 grayman Target Version => TDM 1.08