View Issue Details

IDProjectCategoryView StatusLast Update
0003155The Dark ModTDM Updaterpublic16.10.2012 15:22
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003155: Have updater download most recent version of St. Lucia and Training Map
DescriptionIt probably makes more sense to tell the updater to automatically download St. Lucia rather than bundling it in the mod package. That makes it easier to upload fixed versions and also means people who already have St. Lucia won't get two versions.

The same thing should probably be done for the Training Mission if that's not already how it works.
TagsNo tags attached.

Activities

Springheel

Springheel

14.08.2012 00:53

administrator   ~0004753

St. Lucia will be added as a pk4 when the updates from beta-testing is complete.
grayman

grayman

14.08.2012 01:25

administrator   ~0004758

Last edited: 09.09.2012 17:46

View 2 revisions

The L10N packages should also be included.

grayman

grayman

09.09.2012 17:48

administrator   ~0004818

The updater has a problem with Saint Lucia because that hasn't existed in the darkmod tree before. What happens is the updater downloads the SL pk4 twice rather than once.

Either greebo or I will add code to the updater to correct this.
grayman

grayman

10.09.2012 15:42

administrator   ~0004819

I added code to fix the above problem. Tested.

I won't close this issue until we have an L10N for the training mission and it downloads correctly.
grayman

grayman

16.10.2012 15:22

administrator   ~0004921

This wasn't really an updater issue, but a packaging issue.

Packaging is now set up to include these missions.

The L10N files for both missions will be released AFTER 1.08 ships, due to last-minute text changes and incomplete translations at 1.08 ship time.

Issue History

Date Modified Username Field Change
02.06.2012 12:23 Springheel New Issue
14.08.2012 00:53 Springheel Note Added: 0004753
14.08.2012 01:25 grayman Note Added: 0004758
14.08.2012 01:25 grayman Assigned To => grayman
14.08.2012 01:25 grayman Status new => assigned
09.09.2012 17:46 grayman Note Edited: 0004758 View Revisions
09.09.2012 17:48 grayman Note Added: 0004818
10.09.2012 15:42 grayman Note Added: 0004819
16.10.2012 15:22 grayman Note Added: 0004921
16.10.2012 15:22 grayman Status assigned => resolved
16.10.2012 15:22 grayman Resolution open => fixed
16.10.2012 15:22 grayman Fixed in Version => TDM 1.08