View Issue Details

IDProjectCategoryView StatusLast Update
0003198The Dark ModGUIpublic15.09.2012 12:14
ReporterECHELON Assigned Totels  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformwindowsOSwindowsOS Version7
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003198: Chalice of the Kings freezes on loading with non english menu languages
DescriptionIf you try to start Chalice of the Kings with the menu of dark mod in a language is not english, the mission freezes during the loading.
It always happens.
Steps To ReproduceSet the menu language in a non english language. Start the mission.
TagsNo tags attached.

Activities

Zbyl

Zbyl

14.09.2012 19:07

reporter   ~0004829

Last edited: 14.09.2012 19:08

View 3 revisions

When english language is selected the shop initially shows only "Lockpicks". In other languages (i.e. "Polski") the shop initially shows "Lockpicks", "Triangle Lockpick" and "Snake Lockpick".

The result is that in SetupInventory() adding second copy of a lockpick fails. PutItem() returns NULL and access violation follows.

This bug was introduced in issue 0002376 when "lockpick-set-compression" was added. To be exact, the function CShop::CheckPicks() should not use english item names. So change this:

idStr itemName = list[i]->GetName();
if ((idStr::Icmp(itemName,"Snake Lockpick") == 0) ||
(idStr::Icmp(itemName,"Triangle Lockpick") == 0))

into something like this:

idStr itemName = list[i]->name; // private field!
if ((idStr::Icmp(itemName,"#str_02201") == 0) ||
(idStr::Icmp(itemName,"#str_02200") == 0))

tels

tels

15.09.2012 12:14

reporter   ~0004831

The proposed change was not working, since the itemName is not "#str_02201", but the name in the current language, like "Schlange". But close enough and that comment saved me from searching the cause, so thank you!

Fixed with revision #5570.

Issue History

Date Modified Username Field Change
10.08.2012 21:10 ECHELON New Issue
14.09.2012 19:07 Zbyl Note Added: 0004829
14.09.2012 19:08 Zbyl Note Edited: 0004829 View Revisions
14.09.2012 19:08 Zbyl Note Edited: 0004829 View Revisions
15.09.2012 10:36 tels Summary Chalice of the Kings freezes on loading with non english menĂ¹ languages => Chalice of the Kings freezes on loading with non english menu languages
15.09.2012 10:36 tels Description Updated View Revisions
15.09.2012 10:36 tels Steps to Reproduce Updated View Revisions
15.09.2012 10:37 tels Assigned To => tels
15.09.2012 10:37 tels Status new => assigned
15.09.2012 10:38 tels Target Version => TDM 1.08
15.09.2012 12:14 tels Note Added: 0004831
15.09.2012 12:14 tels Status assigned => resolved
15.09.2012 12:14 tels Fixed in Version => TDM 1.08
15.09.2012 12:14 tels Resolution open => fixed